summaryrefslogtreecommitdiff
path: root/openwrt/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-29 09:51:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-29 09:51:34 +0000
commit25e88c972540f7858e12bc09fcd79978ba9fb01b (patch)
treed4945dce3757008920f3e038c754516c5ea95953 /openwrt/toolchain
parent324544eda2260908023f3d6295fcaca756e96794 (diff)
downloadmtk-20170518-25e88c972540f7858e12bc09fcd79978ba9fb01b.zip
mtk-20170518-25e88c972540f7858e12bc09fcd79978ba9fb01b.tar.gz
mtk-20170518-25e88c972540f7858e12bc09fcd79978ba9fb01b.tar.bz2
make gcc compile install libgcc_s by default, remove package/libgcc/
SVN-Revision: 755
Diffstat (limited to 'openwrt/toolchain')
-rw-r--r--openwrt/toolchain/gcc/gcc-uclibc-3.x.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk b/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk
index e719b87..c7f9495 100644
--- a/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -203,6 +203,9 @@ ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
cp ./$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
endif
endif
+ # These are in /lib, so...
+ cp -a $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
+ $(STRIP) $(TARGET_DIR)/lib/libgcc_s.so.1
gcc: gcc_initial $(LIBFLOAT_TARGET) \
gcc-install $(GCC_TARGETS)