summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-30 20:50:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-30 20:50:17 +0000
commit28da628c0d346220a9ec092d052c1bf4345699a4 (patch)
treea0ca5e951452fdf74edf95f8b61f00b705c3a46f /openwrt
parentd3ff2501726c0dfaa865994636ff108ba2e47dad (diff)
downloadmtk-20170518-28da628c0d346220a9ec092d052c1bf4345699a4.zip
mtk-20170518-28da628c0d346220a9ec092d052c1bf4345699a4.tar.gz
mtk-20170518-28da628c0d346220a9ec092d052c1bf4345699a4.tar.bz2
make the openwrt package dir install the shared includes into the staging dir
SVN-Revision: 1117
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openwrt/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/openwrt/Makefile b/openwrt/package/openwrt/Makefile
index 850c872..71edbee 100644
--- a/openwrt/package/openwrt/Makefile
+++ b/openwrt/package/openwrt/Makefile
@@ -67,6 +67,8 @@ $(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
source: $(DL_DIR)/$(LINKSYS_WLCONF_TGZ)
prepare: $(LINKSYS_WLCONF_DIR)/.unpacked
compile: prepare libnvram-compile libshared-compile $(PKG_IPK) $(PKG_WLCOMPAT)
+ mkdir -p $(STAGING_DIR)/usr/include
+ cp -a ./include/* $(STAGING_DIR)/usr/include/
install: libnvram-install libshared-install \
$(TARGET_DIR)/usr/sbin/wlconf \
$(IPKG_STATE_DIR)/info/$(PKG_NAME).list \