summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-04 01:31:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-04 01:31:03 +0000
commit33a39bc348ef40856153212a5f2ebd37dcef648c (patch)
treeae43f6b2a20939fc8bc11b2ab9eed2ab67b7fffc /openwrt
parent3f3deee507e6ff8ecb996e343f59682ccb701117 (diff)
downloadmtk-20170518-33a39bc348ef40856153212a5f2ebd37dcef648c.zip
mtk-20170518-33a39bc348ef40856153212a5f2ebd37dcef648c.tar.gz
mtk-20170518-33a39bc348ef40856153212a5f2ebd37dcef648c.tar.bz2
don't compile libipkg in busybox if ipkg is disabled
SVN-Revision: 3901
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/busybox/patches/911-ipkg.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/openwrt/package/busybox/patches/911-ipkg.patch b/openwrt/package/busybox/patches/911-ipkg.patch
index 7b6437c..1d7a4e3 100644
--- a/openwrt/package/busybox/patches/911-ipkg.patch
+++ b/openwrt/package/busybox/patches/911-ipkg.patch
@@ -203,16 +203,16 @@ diff -ruN busybox-1.1.2-orig/archival/libipkg/Makefile.in busybox-1.1.2+ipkg-0.9
+ str_util.c \
+ xsystem.c \
+
-+LIBIPKG-y += $(LIBIPKG_CORE_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_CMD_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_DB_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_LIST_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_UTIL_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CORE_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CMD_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_DB_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_LIST_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_UTIL_SOURCES)
+LIBIPKG_OBJS=$(patsubst %.c,$(LIBIPKG_DIR)%.o, $(LIBIPKG-y))
+
+CFLAGS += -DIPKG_LIB -DIPKGLIBDIR="\"/usr/lib\"" -DHOST_CPU_STR="\"$(TARGET_ARCH)\""
+
-+libraries-y += $(LIBIPKG_DIR)$(LIBIPKG_AR)
++libraries-$(CONFIG_IPKG) += $(LIBIPKG_DIR)$(LIBIPKG_AR)
+
+$(LIBIPKG_DIR)$(LIBIPKG_AR): $(LIBIPKG_OBJS)
+ $(do_ar)