summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-07-22 16:33:33 +0000
committerNicolas Thill <nico@openwrt.org>2006-07-22 16:33:33 +0000
commitdf5a64a875511fd080072e26800af6676412348c (patch)
tree8ad3737cadc39c7d1ed00d0842555a109a6a4ba0 /openwrt
parentdaa509ea7fa0b2c79b84cb476aee5dcecae54684 (diff)
downloadmtk-20170518-df5a64a875511fd080072e26800af6676412348c.zip
mtk-20170518-df5a64a875511fd080072e26800af6676412348c.tar.gz
mtk-20170518-df5a64a875511fd080072e26800af6676412348c.tar.bz2
add genext2fs to build ext2 filesystem images
SVN-Revision: 4213
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/include/image.mk2
-rw-r--r--openwrt/toolchain/Makefile2
-rw-r--r--openwrt/toolchain/ext2fs/Makefile30
3 files changed, 32 insertions, 2 deletions
diff --git a/openwrt/include/image.mk b/openwrt/include/image.mk
index 87d6815..ba3cfb8 100644
--- a/openwrt/include/image.mk
+++ b/openwrt/include/image.mk
@@ -47,7 +47,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
define Image/mkfs/ext2
- genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+ $(STAGING_DIR)/bin/genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
$(call Image/Build,ext2)
endef
endif
diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
index 4ffc46f..92069ac 100644
--- a/openwrt/toolchain/Makefile
+++ b/openwrt/toolchain/Makefile
@@ -7,7 +7,7 @@
# Main makefile for the toolchain
#
include $(TOPDIR)/rules.mk
-TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
+TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl ext2fs squashfs jffs2 lzma
TARGETS-$(CONFIG_GDB) += gdb
TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
diff --git a/openwrt/toolchain/ext2fs/Makefile b/openwrt/toolchain/ext2fs/Makefile
new file mode 100644
index 0000000..0bd24f8
--- /dev/null
+++ b/openwrt/toolchain/ext2fs/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=genext2fs
+PKG_VERSION:=1.4rc1
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=664431bf6737df1c265500e1f0b5d40c
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+ install -m0755 $(PKG_BUILD_DIR)/genext2fs $(STAGING_DIR)/bin/
+endef
+
+$(eval $(call HostBuild))