summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-03-27 22:00:12 +0000
committerNicolas Thill <nico@openwrt.org>2006-03-27 22:00:12 +0000
commit21a54709f0d9888fd52921f015b55c93daabc407 (patch)
tree90a421fd6ce0ec63987e9a6aef24d4769141052a /openwrt
parent0af7cb2c68cbbe91f9ceab15c4794e1035b9c465 (diff)
downloadmtk-20170518-21a54709f0d9888fd52921f015b55c93daabc407.zip
mtk-20170518-21a54709f0d9888fd52921f015b55c93daabc407.tar.gz
mtk-20170518-21a54709f0d9888fd52921f015b55c93daabc407.tar.bz2
override cflags set to -O2 by configure
SVN-Revision: 3514
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/libol/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/libol/Makefile b/openwrt/package/libol/Makefile
index 9205184..f027a42 100644
--- a/openwrt/package/libol/Makefile
+++ b/openwrt/package/libol/Makefile
@@ -52,7 +52,9 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
+ # pass CFLAGS again to override -O2 set by configure
$(MAKE) -C $(PKG_BUILD_DIR) \
+ CFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@