summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-03-28 13:42:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-03-28 13:42:33 +0000
commit27d117058cd2071c7fc2f98348f8b735ec7bb0e0 (patch)
treed76eb7d3f2296b87479e38d8d21eabca3e13372c /openwrt
parent773bbceaa012c9e0358a9126e846453276b3a5d9 (diff)
downloadmtk-20170518-27d117058cd2071c7fc2f98348f8b735ec7bb0e0.zip
mtk-20170518-27d117058cd2071c7fc2f98348f8b735ec7bb0e0.tar.gz
mtk-20170518-27d117058cd2071c7fc2f98348f8b735ec7bb0e0.tar.bz2
Remove svn and cvs directories at creation time, fixes #421
SVN-Revision: 3521
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/imagebuilder/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/openwrt/target/linux/imagebuilder/Makefile b/openwrt/target/linux/imagebuilder/Makefile
index 8ed7a5c..4afb4d4 100644
--- a/openwrt/target/linux/imagebuilder/Makefile
+++ b/openwrt/target/linux/imagebuilder/Makefile
@@ -45,4 +45,5 @@ build:
if [ -d ./files.$(LIST) ]; then \
$(CP) --remove-destination ./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
fi
+ find $(LINUX_BUILD_DIR)/root -name '.svn' || 'CVS' | xargs rm -rf
$(MAKE) -S -C image KERNEL="$(KERNEL)" BOARD="$(BOARD)" BIN_DIR="$(BIN_DIR)/$(LIST)" install