summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-04-02 21:59:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-04-02 21:59:18 +0000
commit2ac4ac0fcaa8057735319dd2c99f57435c1141ae (patch)
treed463b1152f0c33cb0bb13620a1c95eb1f9f6e13e /openwrt
parent333b0989aa0eb4223827c7b2e97cd972a504bde8 (diff)
downloadmtk-20170518-2ac4ac0fcaa8057735319dd2c99f57435c1141ae.zip
mtk-20170518-2ac4ac0fcaa8057735319dd2c99f57435c1141ae.tar.gz
mtk-20170518-2ac4ac0fcaa8057735319dd2c99f57435c1141ae.tar.bz2
map xt_ to ipt_ for iptables modules
SVN-Revision: 3586
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index 38eb907..298a9a9 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -21,7 +21,7 @@ define IPKG_plugin_template
$$(IPKG_$(1)):
install -m0755 -d $$(IDIR_$(1))/usr/lib/iptables
- for m in $(2); do \
+ for m in $$(patsubst xt_%,ipt_%,$(2)); do \
$(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$${m}.so $$(IDIR_$(1))/usr/lib/iptables/ ; \
done
@[ -z "$(3)" ] || $(MAKE) $(3)
@@ -76,7 +76,7 @@ $(IPKG_IPTABLES):
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables
(cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
- $(CP) $(patsubst %,lib%.so,$(IPT_BUILTIN)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
+ $(CP) $(patsubst %,lib%.so,$(IPT_BUILTIN:xt_%=ipt_%)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
)
$(RSTRIP) $(IDIR_IPTABLES)
$(IPKG_BUILD) $(IDIR_IPTABLES) $(PACKAGE_DIR)