summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 16:01:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 16:01:46 +0000
commit337621e4682ad459b28f23c2cacebc29a88fbde1 (patch)
treed68bde34fb72b60dfebbac350ca4de6f60de1589 /openwrt
parent7486d2e8d5b442143ce94c0524e86a67b5c338b9 (diff)
downloadmtk-20170518-337621e4682ad459b28f23c2cacebc29a88fbde1.zip
mtk-20170518-337621e4682ad459b28f23c2cacebc29a88fbde1.tar.gz
mtk-20170518-337621e4682ad459b28f23c2cacebc29a88fbde1.tar.bz2
move target/linux/package/switch to package/, fix a bug in the ipkg dependency handling
SVN-Revision: 3864
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/rules.mk3
-rw-r--r--openwrt/package/switch/Makefile44
-rw-r--r--openwrt/package/switch/src/Makefile (renamed from openwrt/target/linux/package/switch/src/Makefile)0
-rw-r--r--openwrt/package/switch/src/etc53xx.h (renamed from openwrt/target/linux/package/switch/src/etc53xx.h)0
-rw-r--r--openwrt/package/switch/src/gpio.h (renamed from openwrt/target/linux/package/switch/src/gpio.h)0
-rw-r--r--openwrt/package/switch/src/switch-adm.c (renamed from openwrt/target/linux/package/switch/src/switch-adm.c)0
-rw-r--r--openwrt/package/switch/src/switch-core.c (renamed from openwrt/target/linux/package/switch/src/switch-core.c)0
-rw-r--r--openwrt/package/switch/src/switch-core.h (renamed from openwrt/target/linux/package/switch/src/switch-core.h)0
-rw-r--r--openwrt/package/switch/src/switch-robo.c (renamed from openwrt/target/linux/package/switch/src/switch-robo.c)0
-rw-r--r--openwrt/target/linux/package/switch/Config.in11
-rw-r--r--openwrt/target/linux/package/switch/Makefile37
-rw-r--r--openwrt/target/linux/package/switch/ipkg/kmod-switch.control4
12 files changed, 45 insertions, 54 deletions
diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index 26b4196..e2e0777 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -134,8 +134,7 @@ define BuildPackage
echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
( \
DEPENDS=; \
- for depend in $$(IDEPEND_$(1)); do \
- [ "$$$${depend%%%%%%%%[A-Za-z]*}" = "@" ] && continue; \
+ for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
done; \
echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
diff --git a/openwrt/package/switch/Makefile b/openwrt/package/switch/Makefile
new file mode 100644
index 0000000..be99a60
--- /dev/null
+++ b/openwrt/package/switch/Makefile
@@ -0,0 +1,44 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(TOPDIR)/package/kernel.mk
+
+PKG_NAME := kmod-switch
+PKG_RELEASE := 1
+PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C "$(LINUX_DIR)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ ARCH="$(LINUX_KARCH)" \
+ PATH="$(TARGET_PATH)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ EXTRA_CFLAGS="-DBCMGPIO2" \
+ modules
+endef
+
+define Package/kmod-switch
+ SECTION:=drivers
+ CATEGORY:=Drivers
+ DEPENDS:=@LINUX_2_6_BRCM||LINUX_2_4_BRCM
+ DEFAULT:=y
+ TITLE:=Switch drivers
+ DESCRIPTION:=Switch drivers for ADM6996L and BCM53XX RoboSwitch
+ VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+
+define Package/kmod-switch/install
+ install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+ $(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
+ $(1)/lib/modules/$(LINUX_VERSION)
+endef
+
+$(eval $(call BuildPackage,kmod-switch))
diff --git a/openwrt/target/linux/package/switch/src/Makefile b/openwrt/package/switch/src/Makefile
index 4c5f911..4c5f911 100644
--- a/openwrt/target/linux/package/switch/src/Makefile
+++ b/openwrt/package/switch/src/Makefile
diff --git a/openwrt/target/linux/package/switch/src/etc53xx.h b/openwrt/package/switch/src/etc53xx.h
index 12d94a5..12d94a5 100644
--- a/openwrt/target/linux/package/switch/src/etc53xx.h
+++ b/openwrt/package/switch/src/etc53xx.h
diff --git a/openwrt/target/linux/package/switch/src/gpio.h b/openwrt/package/switch/src/gpio.h
index 8257600..8257600 100644
--- a/openwrt/target/linux/package/switch/src/gpio.h
+++ b/openwrt/package/switch/src/gpio.h
diff --git a/openwrt/target/linux/package/switch/src/switch-adm.c b/openwrt/package/switch/src/switch-adm.c
index 8d27120..8d27120 100644
--- a/openwrt/target/linux/package/switch/src/switch-adm.c
+++ b/openwrt/package/switch/src/switch-adm.c
diff --git a/openwrt/target/linux/package/switch/src/switch-core.c b/openwrt/package/switch/src/switch-core.c
index 6b59b9b..6b59b9b 100644
--- a/openwrt/target/linux/package/switch/src/switch-core.c
+++ b/openwrt/package/switch/src/switch-core.c
diff --git a/openwrt/target/linux/package/switch/src/switch-core.h b/openwrt/package/switch/src/switch-core.h
index 5292469..5292469 100644
--- a/openwrt/target/linux/package/switch/src/switch-core.h
+++ b/openwrt/package/switch/src/switch-core.h
diff --git a/openwrt/target/linux/package/switch/src/switch-robo.c b/openwrt/package/switch/src/switch-robo.c
index b23fca6..b23fca6 100644
--- a/openwrt/target/linux/package/switch/src/switch-robo.c
+++ b/openwrt/package/switch/src/switch-robo.c
diff --git a/openwrt/target/linux/package/switch/Config.in b/openwrt/target/linux/package/switch/Config.in
deleted file mode 100644
index 0ff2aa1..0000000
--- a/openwrt/target/linux/package/switch/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config PACKAGE_KMOD_SWITCH
- prompt "kmod-switch....................... Kernel driver for ROBO and ADMTEK SWITCH"
- tristate
- default y if LINUX_2_6_BRCM || LINUX_2_4_BRCM
- default m if DEVEL
- default n
- help
- Kernel driver for ROBO and ADMTEK switches.
-
- http://www.openwrt.org
-
diff --git a/openwrt/target/linux/package/switch/Makefile b/openwrt/target/linux/package/switch/Makefile
deleted file mode 100644
index 812fccb..0000000
--- a/openwrt/target/linux/package/switch/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include ../../rules.mk
-
-PKG_NAME := kmod-switch
-PKG_RELEASE := 1
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,KMOD_SWITCH,$(PKG_NAME),$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
-
-$(PKG_BUILD_DIR)/.prepared:
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
- touch $@
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C "$(LINUX_DIR)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- ARCH="$(LINUX_KARCH)" \
- PATH="$(TARGET_PATH)" \
- SUBDIRS="$(PKG_BUILD_DIR)" \
- EXTRA_CFLAGS="-DBCMGPIO2" \
- modules
- touch $@
-
-$(IPKG_KMOD_SWITCH):
- install -m0755 -d $(IDIR_KMOD_SWITCH)/lib/modules/$(LINUX_VERSION)
- $(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
- $(IDIR_KMOD_SWITCH)/lib/modules/$(LINUX_VERSION)
- $(IPKG_BUILD) $(IDIR_KMOD_SWITCH) $(PACKAGE_DIR)
-
diff --git a/openwrt/target/linux/package/switch/ipkg/kmod-switch.control b/openwrt/target/linux/package/switch/ipkg/kmod-switch.control
deleted file mode 100644
index db8a368..0000000
--- a/openwrt/target/linux/package/switch/ipkg/kmod-switch.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: kmod-switch
-Priority: optional
-Section: sys
-Description: switch driver for robo/admtek switch