summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-04-02 01:25:05 +0000
committerNicolas Thill <nico@openwrt.org>2006-04-02 01:25:05 +0000
commit45b8c7eff783d8c82beef5cd0844d16e8c93090b (patch)
treec65a2f185e90f0e83ed530c2ebc19a3cd1534cf4 /openwrt
parent6b9c0e4c6fac144391c2784f538acbde4a58478c (diff)
downloadmtk-20170518-45b8c7eff783d8c82beef5cd0844d16e8c93090b.zip
mtk-20170518-45b8c7eff783d8c82beef5cd0844d16e8c93090b.tar.gz
mtk-20170518-45b8c7eff783d8c82beef5cd0844d16e8c93090b.tar.bz2
fix kmod-fuse build on 2.4
SVN-Revision: 3577
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/package/fuse/patches/101-kmod_build.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch b/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
index feed52a..e541d47 100644
--- a/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
+++ b/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
@@ -25,13 +25,15 @@ diff -Nur fuse-2.5.2/kernel/Makefile.in fuse-2.5.2.patched/kernel/Makefile.in
fuse_headers = fuse_i.h fuse_kernel.h
dev.o: $(fuse_headers)
-@@ -78,6 +63,16 @@
+@@ -78,6 +63,18 @@
file.o: $(fuse_headers)
inode.o: $(fuse_headers)
+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
+
-+obj-m := $(fuse_objs)
++O_TARGET := fuse.o
++
++obj-y := $(fuse_objs)
+obj-m := $(O_TARGET)
+
+-include $(TOPDIR)/Rules.make