summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-20 17:00:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-20 17:00:08 +0000
commitb00ba37ec09d2d802a42d98ca6b8d32b3a0dfda2 (patch)
treee8c0824a7b7088bd768fb6d6145a5aa5fa52dfb1 /openwrt
parent1bf332f3a826fce82cde373911b9fa6c77e42e38 (diff)
downloadmtk-20170518-b00ba37ec09d2d802a42d98ca6b8d32b3a0dfda2.zip
mtk-20170518-b00ba37ec09d2d802a42d98ca6b8d32b3a0dfda2.tar.gz
mtk-20170518-b00ba37ec09d2d802a42d98ca6b8d32b3a0dfda2.tar.bz2
package kmod-diag
SVN-Revision: 687
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/linux/Config.in6
-rw-r--r--openwrt/package/linux/Makefile3
-rw-r--r--openwrt/package/linux/control/kmod-diag.control6
-rw-r--r--openwrt/package/linux/linux.mk1
4 files changed, 15 insertions, 1 deletions
diff --git a/openwrt/package/linux/Config.in b/openwrt/package/linux/Config.in
index 2ab006c..6f73d97 100644
--- a/openwrt/package/linux/Config.in
+++ b/openwrt/package/linux/Config.in
@@ -1,3 +1,9 @@
+config BR2_PACKAGE_KMOD_DIAG
+ tristate "Router LED/Button Driver"
+ default y
+ help
+ Driver for the LEDs on Wireless Routers (diag)
+
config BR2_PACKAGE_KMOD_BRCM_WL
tristate "Broadcom Wireless Network Driver"
default y
diff --git a/openwrt/package/linux/Makefile b/openwrt/package/linux/Makefile
index fdd7e8d..4d94212 100644
--- a/openwrt/package/linux/Makefile
+++ b/openwrt/package/linux/Makefile
@@ -39,6 +39,9 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
endef
+$(eval $(call KMOD_template,DIAG,diag,\
+ $(MODULES_DIR)/kernel/drivers/net/diag/diag.o \
+))
$(eval $(call KMOD_template,BRCM_WL,brcm-wl,\
$(MODULES_DIR)/kernel/drivers/net/wl/wl.o \
,CONFIG_WL))
diff --git a/openwrt/package/linux/control/kmod-diag.control b/openwrt/package/linux/control/kmod-diag.control
new file mode 100644
index 0000000..8e7603c
--- /dev/null
+++ b/openwrt/package/linux/control/kmod-diag.control
@@ -0,0 +1,6 @@
+Package: kmod-diag
+Priority: essential
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Driver for Router LEDs and Buttons
diff --git a/openwrt/package/linux/linux.mk b/openwrt/package/linux/linux.mk
index c443e65..43417a4 100644
--- a/openwrt/package/linux/linux.mk
+++ b/openwrt/package/linux/linux.mk
@@ -95,7 +95,6 @@ $(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
$(TARGET_MODULES_DIR):
-mkdir -p $(TARGET_MODULES_DIR)
- cp $(LINUX_DIR)/drivers/net/diag/diag.o $(TARGET_MODULES_DIR)
linux: $(LINUX_DIR)/.modules_done $(TARGET_MODULES_DIR)