summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-24 23:45:28 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-24 23:45:28 +0000
commit567502494a6c6586eb6ff3c2aff9b31d5582fd10 (patch)
treee2fb7e4ad21780aeee9972d1e3f3bbdce89def9e /openwrt
parent0e9ab0b18e48c5487eca693cff28fed68a3b3627 (diff)
downloadmtk-20170518-567502494a6c6586eb6ff3c2aff9b31d5582fd10.zip
mtk-20170518-567502494a6c6586eb6ff3c2aff9b31d5582fd10.tar.gz
mtk-20170518-567502494a6c6586eb6ff3c2aff9b31d5582fd10.tar.bz2
add support for multiple target arch
SVN-Revision: 1543
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 8305f9c..5b6c71d 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -188,7 +188,7 @@ $(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched
-cp $(LINUX_KCONFIG) $(LINUX_DIR)/.config
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" \
$(LINUX_DIR)/Makefile \
- $(LINUX_DIR)/arch/mips/Makefile
+ $(LINUX_DIR)/arch/*/Makefile
$(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile
$(MAKE) -C $(LINUX_DIR) ARCH=$(LINUX_KARCH) oldconfig include/linux/version.h
touch $(LINUX_DIR)/.configured