summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-18 01:58:27 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-18 01:58:27 +0000
commit5824225005e76a5d63e0002bf8895104631e494c (patch)
tree5ed62f57637738308a83759daf7a397a2a60aeb3 /openwrt
parent57781a24107b7f5f098b5da2924aa6eff90bf1ac (diff)
downloadmtk-20170518-5824225005e76a5d63e0002bf8895104631e494c.zip
mtk-20170518-5824225005e76a5d63e0002bf8895104631e494c.tar.gz
mtk-20170518-5824225005e76a5d63e0002bf8895104631e494c.tar.bz2
fix libmad build when arch != mipsel
SVN-Revision: 2173
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/libmad/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/openwrt/package/libmad/Makefile b/openwrt/package/libmad/Makefile
index 4a979d0..977248d 100644
--- a/openwrt/package/libmad/Makefile
+++ b/openwrt/package/libmad/Makefile
@@ -19,6 +19,14 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,LIBMAD,libmad,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+FPM:=default
+ifeq ($(ARCH),i386)
+FPM:=intel
+endif
+ifeq ($(ARCH),mipsel)
+FPM:=mips
+endif
+
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
@@ -50,7 +58,7 @@ $(PKG_BUILD_DIR)/.configured:
--enable-static \
--disable-rpath \
--with-gnu-ld \
- --enable-fpm=mips \
+ --enable-fpm=$(FPM) \
--disable-debugging \
--enable-speed \
);