summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-02-12 18:47:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-02-12 18:47:22 +0000
commit58713c8d76c4a1a6658cbd46822a2f8104e88c7d (patch)
tree000bfcd986794b3f6ec30438d4edc311c092489a /openwrt
parent5d0330daf97e2df18369ab650cc0e7b9e512b95a (diff)
downloadmtk-20170518-58713c8d76c4a1a6658cbd46822a2f8104e88c7d.zip
mtk-20170518-58713c8d76c4a1a6658cbd46822a2f8104e88c7d.tar.gz
mtk-20170518-58713c8d76c4a1a6658cbd46822a2f8104e88c7d.tar.bz2
name sercomm-based ar7 images (dg834/compatible) .img instead of .bin, because the web interface expects it
SVN-Revision: 3228
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index 3a803cb..2cdf18d 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -84,13 +84,13 @@ install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS)-$(1).bin
endef
define sercomm_template
-$(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).bin
+$(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).img: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).bin
cat sercomm/adam2.bin "$$^" > "$$@.tmp"
dd if=sercomm/$(1) of="$$@.tmp" bs=$$$$((0x3e0000 - 80)) seek=1 conv=notrunc
$(STAGING_DIR)/bin/dgfirmware -f -w "$$@" "$$@.tmp"
rm -f "$$@.tmp"
-install: $(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).bin
+install: $(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).img
endef
$(eval $(call sercomm_template,dg834))