summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-05-17 01:07:20 +0000
committerNicolas Thill <nico@openwrt.org>2006-05-17 01:07:20 +0000
commitc8c1e1372d380db1c58504bdc9a315494eb5a9fd (patch)
treef447038af3b96950b3012d377c3a64051fec29ea /openwrt
parentc638b79f98d1a58c4907f6cca5cc4ad9859e283f (diff)
downloadmtk-20170518-c8c1e1372d380db1c58504bdc9a315494eb5a9fd.zip
mtk-20170518-c8c1e1372d380db1c58504bdc9a315494eb5a9fd.tar.gz
mtk-20170518-c8c1e1372d380db1c58504bdc9a315494eb5a9fd.tar.bz2
fix rebuild of pwlib and openh323 after root_clean.
SVN-Revision: 3791
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openh323/Makefile8
-rw-r--r--openwrt/package/pwlib/Makefile8
2 files changed, 6 insertions, 10 deletions
diff --git a/openwrt/package/openh323/Makefile b/openwrt/package/openh323/Makefile
index a17ac00..f85e623 100644
--- a/openwrt/package/openh323/Makefile
+++ b/openwrt/package/openh323/Makefile
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
--enable-audio \
--disable-video \
);
+ ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
touch $@
@@ -58,11 +59,8 @@ $(PKG_BUILD_DIR)/.built:
optnoshared
touch $@
-install-link:
- ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
uninstall-link:
- rm -rf $(BUILD_DIR)/$(PKG_NAME)
+ rm -f $(BUILD_DIR)/$(PKG_NAME)
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
clean-targets: uninstall-link
diff --git a/openwrt/package/pwlib/Makefile b/openwrt/package/pwlib/Makefile
index 66e806d..68857ff 100644
--- a/openwrt/package/pwlib/Makefile
+++ b/openwrt/package/pwlib/Makefile
@@ -88,6 +88,7 @@ $(PKG_BUILD_DIR)/.configured:
--disable-wavfile \
--disable-xmlrpc \
);
+ ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
touch $@
$(PKG_BUILD_DIR)/.built:
@@ -96,11 +97,8 @@ $(PKG_BUILD_DIR)/.built:
optnoshared
touch $@
-install-link:
- ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
uninstall-link:
- rm -rf $(BUILD_DIR)/$(PKG_NAME)
+ rm -f $(BUILD_DIR)/$(PKG_NAME)
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
clean-targets: uninstall-link