summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-15 08:49:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-15 08:49:02 +0000
commitf9789428092a74816e597ad9a259105cd371b50b (patch)
tree0d47f7a1eeff1775f91daf82360602127343d410 /openwrt
parent4768b3cc3f4ed639f4b32a15be95708bf6ea816b (diff)
downloadmtk-20170518-f9789428092a74816e597ad9a259105cd371b50b.zip
mtk-20170518-f9789428092a74816e597ad9a259105cd371b50b.tar.gz
mtk-20170518-f9789428092a74816e597ad9a259105cd371b50b.tar.bz2
fix external package build
SVN-Revision: 1682
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/package/fuse/Makefile3
-rw-r--r--openwrt/target/linux/package/madwifi/Makefile3
-rw-r--r--openwrt/target/linux/package/openswan/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/openwrt/target/linux/package/fuse/Makefile b/openwrt/target/linux/package/fuse/Makefile
index 5d1dc89..9c66cea 100644
--- a/openwrt/target/linux/package/fuse/Makefile
+++ b/openwrt/target/linux/package/fuse/Makefile
@@ -1,6 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
+include ../../rules.mk
PKG_NAME:=fuse
PKG_VERSION:=2.2.1
@@ -66,7 +67,7 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built:
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
- ARCH="$(ARCH)" \
+ ARCH="$(LINUX_KARCH)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
SUBDIRS="kernel" \
all install
diff --git a/openwrt/target/linux/package/madwifi/Makefile b/openwrt/target/linux/package/madwifi/Makefile
index bde33e2..4e1a7d3 100644
--- a/openwrt/target/linux/package/madwifi/Makefile
+++ b/openwrt/target/linux/package/madwifi/Makefile
@@ -1,6 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
+include ../../rules.mk
PKG_NAME:=madwifi
PKG_VERSION:=2005-08-13
@@ -36,7 +37,7 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
- ARCH="$(ARCH)" \
+ ARCH="$(LINUX_KARCH)" \
TARGET="$(HAL_TARGET)" \
TOOLPREFIX="$(KERNEL_CROSS)" \
KERNELPATH="$(KERNEL_DIR)"
diff --git a/openwrt/target/linux/package/openswan/Makefile b/openwrt/target/linux/package/openswan/Makefile
index a105a1f..d54ffae 100644
--- a/openwrt/target/linux/package/openswan/Makefile
+++ b/openwrt/target/linux/package/openswan/Makefile
@@ -1,6 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
+include ../../rules.mk
PKG_NAME:=openswan
PKG_VERSION:=2.3.1
@@ -26,7 +27,7 @@ $(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
KERNELSRC="$(KERNEL_DIR)" \
- ARCH="mips" \
+ ARCH="$(LINUX_KARCH)" \
USERCOMPILE="$(FLAGS)" \
module