summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-21 22:19:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-21 22:19:21 +0000
commit4f9884d1be783f8130f9066e58d7085b15d1a40f (patch)
tree9e6adfe942098091580717edcd5532fa9c36bf16 /openwrt
parentb6f60e59c24c4c63c9f78fba28cfaf722357bfce (diff)
downloadmtk-20170518-4f9884d1be783f8130f9066e58d7085b15d1a40f.zip
mtk-20170518-4f9884d1be783f8130f9066e58d7085b15d1a40f.tar.gz
mtk-20170518-4f9884d1be783f8130f9066e58d7085b15d1a40f.tar.bz2
move modules.d stuff in /etc/init.d/S10boot and make it more like /etc/modules
SVN-Revision: 703
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openwrt/Makefile2
-rwxr-xr-xopenwrt/target/default/target_skeleton/etc/init.d/S10boot2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/openwrt/Makefile b/openwrt/package/openwrt/Makefile
index 01c830d..ea2bfd8 100644
--- a/openwrt/package/openwrt/Makefile
+++ b/openwrt/package/openwrt/Makefile
@@ -84,7 +84,7 @@ $(PKG_BUILD_DIR)/wlcompat-debug.o:
$(PKG_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/wlcompat kmod-wlcompat.control $(LINUX_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(PKG_BUILD_DIR)/wlcompat/etc/modules.d
- echo "insmod wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
+ echo "wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
mkdir -p $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)
cp $^ $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(PKG_BUILD_DIR)/wlcompat $(PACKAGE_DIR)
diff --git a/openwrt/target/default/target_skeleton/etc/init.d/S10boot b/openwrt/target/default/target_skeleton/etc/init.d/S10boot
index 9904807..47a255d 100755
--- a/openwrt/target/default/target_skeleton/etc/init.d/S10boot
+++ b/openwrt/target/default/target_skeleton/etc/init.d/S10boot
@@ -25,7 +25,7 @@ touch /var/log/lastlog
}
}
-sed 's/^[^#]/insmod &/' /etc/modules 2>&-|ash
+cat /etc/modules /etc/modules.d/* | sed 's/^[^#]/insmod &/' 2>&-|ash
ifconfig lo 127.0.0.1 up
ifconfig eth0 promisc