summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-07 15:11:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-07 15:11:58 +0000
commit06469aeee1edab1b759c4f3bc9efb40db681190b (patch)
tree063113af2e3b1b9f2c4f7ea87a5e575be5855492 /openwrt
parent947a85081d306dc8aaab215a923407d73cd9643d (diff)
downloadmtk-20170518-06469aeee1edab1b759c4f3bc9efb40db681190b.zip
mtk-20170518-06469aeee1edab1b759c4f3bc9efb40db681190b.tar.gz
mtk-20170518-06469aeee1edab1b759c4f3bc9efb40db681190b.tar.bz2
create a package index after build
SVN-Revision: 337
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index ed4ea15..1a218df 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -69,16 +69,13 @@ package_install: toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install
+world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
-#############################################################
-#
-# staging and target directories do NOT list these as
-# dependancies anywhere else
-#
-#############################################################
+package_index:
+ $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+
target_prepare:
$(MAKE) -C target prepare