summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-13 14:39:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-13 14:39:56 +0000
commit0646dd2c716ceb06e316203748a4c92ba36407a0 (patch)
tree0748edaef275c9faf7da1018419f487c52464805 /openwrt
parent100a739998cb3a8a1b6ed09a013aaa7c9b64a5e0 (diff)
downloadmtk-20170518-0646dd2c716ceb06e316203748a4c92ba36407a0.zip
mtk-20170518-0646dd2c716ceb06e316203748a4c92ba36407a0.tar.gz
mtk-20170518-0646dd2c716ceb06e316203748a4c92ba36407a0.tar.bz2
fix trx alignment
SVN-Revision: 1226
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index 25f4ea9..3399047 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -14,8 +14,15 @@ lzma-loader-compile: lzma-loader-prepare
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
+ifeq ($(FS),jffs2-8MB)
+TRXALIGN:=-a 0x20000
+endif
+ifeq ($(FS),jffs2-4MB)
+TRXALIGN:=-a 0x10000
+endif
$(BIN_DIR)/openwrt-brcm-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma
- $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(KDIR)/root.$(FS)
+ $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))