summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-09 13:41:43 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-09 13:41:43 +0000
commit1e99b4082e4d8070f9961cf500c4dfed07f76c07 (patch)
tree0d26d24c24b075fd7ce4fa5bfc6bd774d60ad798 /openwrt
parent0fc464f14359529daa5df4e0491022d9898c3534 (diff)
downloadmtk-20170518-1e99b4082e4d8070f9961cf500c4dfed07f76c07.zip
mtk-20170518-1e99b4082e4d8070f9961cf500c4dfed07f76c07.tar.gz
mtk-20170518-1e99b4082e4d8070f9961cf500c4dfed07f76c07.tar.bz2
Tweak openswan: strip kernel module and remove /var from package
SVN-Revision: 598
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openswan/Makefile3
-rw-r--r--openwrt/package/openswan/patches/scripts.patch2
2 files changed, 4 insertions, 1 deletions
diff --git a/openwrt/package/openswan/Makefile b/openwrt/package/openswan/Makefile
index b652e1e..6171656 100644
--- a/openwrt/package/openswan/Makefile
+++ b/openwrt/package/openswan/Makefile
@@ -57,11 +57,14 @@ $(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-$(STRIP) $(PKG_IPK_DIR)/usr/libexec/ipsec/*
rm -rf $(PKG_IPK_DIR)/usr/share
rm -rf $(PKG_IPK_DIR)/usr/man
+ rm -rf $(PKG_IPK_DIR)/var
rm -rf $(PKG_IPK_DIR)/etc/rc.d/rc*.d
mkdir -p $(PKG_IPK_DIR)/etc/init.d
ln -sf ../rc.d/init.d/ipsec $(PKG_IPK_DIR)/etc/init.d/S60ipsec
mkdir -p $(PKG_IPK_DIR)/lib/modules/$(LINUX_VERSION)
cp $(PKG_BUILD_DIR)/modobj/ipsec.o $(PKG_IPK_DIR)/lib/modules/$(LINUX_VERSION)/
+ $(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note \
+ $(PKG_IPK_DIR)/lib/modules/$(LINUX_VERSION)/ipsec.o
mkdir -p $(PACKAGE_DIR)
find $(PKG_BUILD_DIR) -name \*.old | xargs rm -rf
$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
diff --git a/openwrt/package/openswan/patches/scripts.patch b/openwrt/package/openswan/patches/scripts.patch
index 7e908ed..45296f0 100644
--- a/openwrt/package/openswan/patches/scripts.patch
+++ b/openwrt/package/openswan/patches/scripts.patch
@@ -63,7 +63,7 @@ diff -uNr openswan-2.3.0.orig/programs/setup/setup.in openswan-2.3.0/programs/se
fi
+
+ # make sure all required directories exist
-+ if [ ! -d /var/run ]
++ if [ ! -d /var/run/pluto ]
+ then
+ mkdir -p /var/run/pluto
+ fi