summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-07 16:25:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-07 16:25:40 +0000
commitce531c82b3f03dd8d1ec33d8047a4402f4a71e25 (patch)
treea22f5c9eadfce255070d39e46257b82af2cf70c8 /openwrt
parent43a504e7447abfc26c4284366a17250c34b17728 (diff)
downloadmtk-20170518-ce531c82b3f03dd8d1ec33d8047a4402f4a71e25.zip
mtk-20170518-ce531c82b3f03dd8d1ec33d8047a4402f4a71e25.tar.gz
mtk-20170518-ce531c82b3f03dd8d1ec33d8047a4402f4a71e25.tar.bz2
fix package_index
SVN-Revision: 339
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 1a218df..04a07dd 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -74,7 +74,9 @@ world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install pac
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
package_index:
- $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+ (cd $(PACKAGE_DIR); \
+ $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
+ )
target_prepare:
$(MAKE) -C target prepare