summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-02 10:43:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-02 10:43:04 +0000
commitd2a31e404c9392a3f532a99e20ea65c96493748c (patch)
tree65a082a1c435a326f0bd21b14444aabeaba8dc34 /openwrt
parent713202a17fe0db6245ea91e18913e94cc28402ab (diff)
downloadmtk-20170518-d2a31e404c9392a3f532a99e20ea65c96493748c.zip
mtk-20170518-d2a31e404c9392a3f532a99e20ea65c96493748c.tar.gz
mtk-20170518-d2a31e404c9392a3f532a99e20ea65c96493748c.tar.bz2
fix build depends for wlc
SVN-Revision: 512
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openwrt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/openwrt/Makefile b/openwrt/package/openwrt/Makefile
index 4c129fd..1580c13 100644
--- a/openwrt/package/openwrt/Makefile
+++ b/openwrt/package/openwrt/Makefile
@@ -10,10 +10,10 @@ PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
SHARED_INCLUDE:=${shell pwd}/include
-libshared-compile libnvram-compile wlc-compile:
+libshared-compile libnvram-compile:
@$(MAKE) -C $(patsubst %-compile,%,$@) compile
-libshared-install libnvram-install wlc-install:
+libshared-install libnvram-install: libshared-compile libnvram-compile
@$(MAKE) -C $(patsubst %-install,%,$@) install
libshared-clean libnvram-clean wlc-clean:
@@ -27,7 +27,7 @@ $(PKG_IPK_DIR)/sbin/jffs2root: jffs2root.c
mkdir -p $(PKG_IPK_DIR)/sbin
$(TARGET_CC) -o $@ $<
-$(PKG_IPK_DIR)/usr/sbin/wlc: wlc.c libshared-compile
+$(PKG_IPK_DIR)/usr/sbin/wlc: wlc.c libshared-install
mkdir -p $(PKG_IPK_DIR)/usr/sbin
$(TARGET_CC) -o $@ $< -lshared -L./libshared -I$(SHARED_INCLUDE)