summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-16 10:12:08 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-16 10:12:08 +0000
commit6cdbdb72685b5273535b49f6c1bbb558aab6cfc8 (patch)
tree396d907b2130e0287299b9718662df91dd62fe1a /openwrt
parent15ae1237716616bb37218ca93d400858375c7703 (diff)
downloadmtk-20170518-6cdbdb72685b5273535b49f6c1bbb558aab6cfc8.zip
mtk-20170518-6cdbdb72685b5273535b49f6c1bbb558aab6cfc8.tar.gz
mtk-20170518-6cdbdb72685b5273535b49f6c1bbb558aab6cfc8.tar.bz2
use aligned trx for 128kb flash size for netgear, reported by Kaloz
SVN-Revision: 1931
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index abba131..23072bd 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -30,12 +30,14 @@ $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
ifeq ($(KERNEL),2.6)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+ifneq ($(FS),jffs2-4MB)
$(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
dd if=$(BUILD_DIR)/loader.elf of=$@ bs=131072 conv=sync
cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
install: $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
endif
+endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))