summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-01-05 22:19:28 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-01-05 22:19:28 +0000
commit97ac80e13fdde1681c12245101870a2d044e59c2 (patch)
tree6b057d2d332e58e5b8a59b95cbf1471c01c8e651 /openwrt
parent59611c967485bf6d1d9f923ef81a350fa6974ca1 (diff)
downloadmtk-20170518-97ac80e13fdde1681c12245101870a2d044e59c2.zip
mtk-20170518-97ac80e13fdde1681c12245101870a2d044e59c2.tar.gz
mtk-20170518-97ac80e13fdde1681c12245101870a2d044e59c2.tar.bz2
Added wlan_scan_ap, wlan_scan_sta, and missing crypto, xauth ... modules mentioned by the 20-madwifi file, closes #179
SVN-Revision: 2842
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/package/madwifi/Makefile1
-rw-r--r--openwrt/target/linux/package/madwifi/files/madwifi.modules2
2 files changed, 3 insertions, 0 deletions
diff --git a/openwrt/target/linux/package/madwifi/Makefile b/openwrt/target/linux/package/madwifi/Makefile
index d5f5535..ea2197c 100644
--- a/openwrt/target/linux/package/madwifi/Makefile
+++ b/openwrt/target/linux/package/madwifi/Makefile
@@ -56,6 +56,7 @@ $(IPKG_KMOD_MADWIFI):
$(PKG_BUILD_DIR)/ath_hal/ath_hal.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/ath/ath_pci.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/ath_rate/sample/ath_rate_sample.$(LINUX_KMOD_SUFFIX) \
+ $(PKG_BUILD_DIR)/net80211/*.$(LINUX_KMOD_SUFFIX) \
$(IDIR_KMOD_MADWIFI)/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(IDIR_KMOD_MADWIFI) $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/package/madwifi/files/madwifi.modules b/openwrt/target/linux/package/madwifi/files/madwifi.modules
index eb8ca2e..996b8e7 100644
--- a/openwrt/target/linux/package/madwifi/files/madwifi.modules
+++ b/openwrt/target/linux/package/madwifi/files/madwifi.modules
@@ -7,3 +7,5 @@ wlan_ccmp
wlan_tkip
wlan_wep
wlan_xauth
+wlan_scan_ap
+wlan_scan_sta