summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-23 15:17:15 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-23 15:17:15 +0000
commitc3625bfc7fadbb2ab55b5598039fdd2a3f50b4ac (patch)
tree9b3f73bbc6f658fc746d173c0cf842de0bc53dc4 /openwrt
parent778c67ae8593feb028f69184c6a5b9df10b23a64 (diff)
downloadmtk-20170518-c3625bfc7fadbb2ab55b5598039fdd2a3f50b4ac.zip
mtk-20170518-c3625bfc7fadbb2ab55b5598039fdd2a3f50b4ac.tar.gz
mtk-20170518-c3625bfc7fadbb2ab55b5598039fdd2a3f50b4ac.tar.bz2
add missing pg_config.h header to staging_dir, required to build php5 extension
SVN-Revision: 1737
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index 1f37bb7..d83f1af 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -97,6 +97,7 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
@@ -109,6 +110,7 @@ uninstall-dev:
rm -rf \
$(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
+ $(STAGING_DIR)/usr/include/pg_config.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \
$(STAGING_DIR)/usr/lib/libpq.{a,so*} \