summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-11 21:13:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-11 21:13:46 +0000
commitc90793463c2602b951b71d629a6530bab2be50d0 (patch)
treef20dcdddb64ce81a2df22248eb4d524168d43353 /openwrt
parentf48d720726633258240f97ce8759b8d9c3572cd3 (diff)
downloadmtk-20170518-c90793463c2602b951b71d629a6530bab2be50d0.zip
mtk-20170518-c90793463c2602b951b71d629a6530bab2be50d0.tar.gz
mtk-20170518-c90793463c2602b951b71d629a6530bab2be50d0.tar.bz2
fix wificonf build depends
SVN-Revision: 1204
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/openwrt/libnvram/Makefile6
-rw-r--r--openwrt/package/openwrt/libshared/Makefile6
3 files changed, 9 insertions, 4 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 4fbcf83..f9768de 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -127,6 +127,7 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
compile: $(patsubst %,%-compile,$(package-y) $(package-m))
install: $(patsubst %,%-install,$(package-y))
+wificonf-compile: openwrt-compile wireless-tools-compile
arpwatch-compile: libpcap-compile
cyrus-sasl-compile: openssl-compile
dropbear-compile: zlib-compile
diff --git a/openwrt/package/openwrt/libnvram/Makefile b/openwrt/package/openwrt/libnvram/Makefile
index 75a1afc..a5b6284 100644
--- a/openwrt/package/openwrt/libnvram/Makefile
+++ b/openwrt/package/openwrt/libnvram/Makefile
@@ -26,10 +26,12 @@ $(PKG_BUILD_DIR)/nvram: $(PKG_BUILD_DIR)/main.o $(PKG_BUILD_DIR)/libnvram.so
$(PKG_BUILD_DIR)/libnvram.so: $(LIBNVRAM_OBJS)
$(TARGET_CC) -shared -o $@ $^
+
+$(STAGING_DIR)/lib/libnvram.so: $(PKG_BUILD_DIR)/libnvram.so
+ install -m 644 $< $@
$(TARGET_DIR)/usr/lib/libnvram.so: $(PKG_BUILD_DIR)/libnvram.so
install -m 644 $< $@
- install -m 644 $< $(STAGING_DIR)/lib/libnvram.so
$(STRIP) $@
$(TARGET_DIR)/usr/sbin/nvram: $(PKG_BUILD_DIR)/nvram
@@ -37,7 +39,7 @@ $(TARGET_DIR)/usr/sbin/nvram: $(PKG_BUILD_DIR)/nvram
install -m 755 $< $@
$(STRIP) $@
-compile: $(PKG_BUILD_DIR)/libnvram.so $(PKG_BUILD_DIR)/nvram
+compile: $(PKG_BUILD_DIR)/libnvram.so $(STAGING_DIR)/lib/libnvram.so $(PKG_BUILD_DIR)/nvram
install: $(TARGET_DIR)/usr/lib/libnvram.so $(TARGET_DIR)/usr/sbin/nvram
clean:
diff --git a/openwrt/package/openwrt/libshared/Makefile b/openwrt/package/openwrt/libshared/Makefile
index 601dc66..4309c8c 100644
--- a/openwrt/package/openwrt/libshared/Makefile
+++ b/openwrt/package/openwrt/libshared/Makefile
@@ -26,12 +26,14 @@ $(PKG_BUILD_DIR):
$(PKG_BUILD_DIR)/libshared.so: $(LIBSHARED_OBJS)
$(TARGET_CC) -shared -o $@ $^
+$(STAGING_DIR)/lib/libshared.so: $(PKG_BUILD_DIR)/libshared.so
+ install -m 644 $< $@
+
$(TARGET_DIR)/usr/lib/libshared.so: $(PKG_BUILD_DIR)/libshared.so
install -m 644 $^ $@
- install -m 644 $^ $(STAGING_DIR)/lib/libshared.so
$(STRIP) $@
-compile: $(PKG_BUILD_DIR)/libshared.so
+compile: $(PKG_BUILD_DIR)/libshared.so $(STAGING_DIR)/lib/libshared.so
install: $(TARGET_DIR)/usr/lib/libshared.so
clean: