summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-08-29 10:47:33 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-08-29 10:47:33 +0000
commitdd7c30306de45867a23dc21ea9505cf5f950b04e (patch)
tree89b52e0d28c43c08ef95ba7214343a266d48d79d /openwrt
parent1c9a8190d89c6e57093b61db8a4877b94b13334d (diff)
downloadmtk-20170518-dd7c30306de45867a23dc21ea9505cf5f950b04e.zip
mtk-20170518-dd7c30306de45867a23dc21ea9505cf5f950b04e.tar.gz
mtk-20170518-dd7c30306de45867a23dc21ea9505cf5f950b04e.tar.bz2
make a image for netgear, loader need to be ELF
SVN-Revision: 1784
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index c0c83c5..09f2d14 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -27,6 +27,15 @@ endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
$(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+ifeq ($(KERNEL),2.6)
+FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+
+$(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ dd if=$(BUILD_DIR)/loader-0.04/loader.o of=$@ bs=65536 conv=sync
+ cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
+
+install: $(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin
+endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))