summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-05 14:05:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-05 14:05:22 +0000
commitde60731de355c3d585677f4f5256597655667379 (patch)
treee2a1556754db34cbe8d9adf0fa20456e6be97bb8 /openwrt
parent0ab6153f25dffc82b04ad8da05388f967dfa587b (diff)
downloadmtk-20170518-de60731de355c3d585677f4f5256597655667379.zip
mtk-20170518-de60731de355c3d585677f4f5256597655667379.tar.gz
mtk-20170518-de60731de355c3d585677f4f5256597655667379.tar.bz2
add target package/target_name to the master makefile, which will run $(MAKE) -C package target_name. same for target/ and toolchain/
SVN-Revision: 1147
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index e935295..1b8d968 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -74,7 +74,6 @@ package_install: package_compile toolchain
#
#############################################################
-
# In this section, we need .config
include .config.cmd
@@ -108,6 +107,16 @@ $(BUILD_DIR):
source: $(TARGETS_SOURCE)
+
+package/%:
+ $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+ $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+ $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
#############################################################
#
# Cleanup and misc junk