summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-05 15:38:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-05 15:38:04 +0000
commitf8c8700d6044a2b74289c15c28c4144c87fd293f (patch)
treea7a00887e1a8c52c9403d4ac1f1cab8943314b27 /openwrt
parentb7216f0b13b029c42c9a83ba86319bba8eb2a0ed (diff)
downloadmtk-20170518-f8c8700d6044a2b74289c15c28c4144c87fd293f.zip
mtk-20170518-f8c8700d6044a2b74289c15c28c4144c87fd293f.tar.gz
mtk-20170518-f8c8700d6044a2b74289c15c28c4144c87fd293f.tar.bz2
Avoid mkdir in postinst, doing it in the Makefile
SVN-Revision: 3138
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/quagga/Makefile1
-rw-r--r--openwrt/package/quagga/ipkg/quagga.postinst1
2 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/package/quagga/Makefile b/openwrt/package/quagga/Makefile
index e08688c..a1cc122 100644
--- a/openwrt/package/quagga/Makefile
+++ b/openwrt/package/quagga/Makefile
@@ -81,6 +81,7 @@ $(IPKG_QUAGGA):
install -d -m0755 $(IDIR_QUAGGA)/etc/init.d/
install -m0755 ./files/quagga.init $(IDIR_QUAGGA)/etc/init.d/quagga
ln -sf quagga $(IDIR_QUAGGA)/etc/init.d/S49quagga
+ install -m0755 $(IDIR_QUAGGA)/var/run/quagga
$(RSTRIP) $(IDIR_QUAGGA)
$(IPKG_BUILD) $(IDIR_QUAGGA) $(PACKAGE_DIR)
diff --git a/openwrt/package/quagga/ipkg/quagga.postinst b/openwrt/package/quagga/ipkg/quagga.postinst
index ff83cfc..90ffe61 100644
--- a/openwrt/package/quagga/ipkg/quagga.postinst
+++ b/openwrt/package/quagga/ipkg/quagga.postinst
@@ -45,5 +45,4 @@ echo "ospfapi 2607/tcp" >>${IPKG_INSTROOT}/etc/services
echo "isisd 2608/tcp" >>${IPKG_INSTROOT}/etc/services
fi
-mkdir -p $dir
chown -R $name:$name $dir