summaryrefslogtreecommitdiff
path: root/package/ead/src/tinysrp/Makefile.am
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-12-24 10:42:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-12-24 10:42:12 +0000
commit2d86ea2a1d66045472b405d7395a9732f3340f94 (patch)
tree44d30dc88e3fd191ab22e729a32c1267381af70b /package/ead/src/tinysrp/Makefile.am
parent067e900705377b83a21fd7cb0cebd9f850e8d379 (diff)
downloadmtk-20170518-2d86ea2a1d66045472b405d7395a9732f3340f94.zip
mtk-20170518-2d86ea2a1d66045472b405d7395a9732f3340f94.tar.gz
mtk-20170518-2d86ea2a1d66045472b405d7395a9732f3340f94.tar.bz2
add the 'ead' package (emergency access daemon), which can provide remote access to your device, even if the ip and firewall settings are broken
SVN-Revision: 13738
Diffstat (limited to 'package/ead/src/tinysrp/Makefile.am')
-rw-r--r--package/ead/src/tinysrp/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/ead/src/tinysrp/Makefile.am b/package/ead/src/tinysrp/Makefile.am
new file mode 100644
index 0000000..a8f899f
--- /dev/null
+++ b/package/ead/src/tinysrp/Makefile.am
@@ -0,0 +1,28 @@
+AUTOMAKE_OPTIONS = foreign no-dependencies
+
+noinst_HEADERS = t_client.h t_pwd.h t_server.h t_sha.h \
+ bn.h bn_lcl.h bn_prime.h t_defines.h t_read.h
+
+include_HEADERS = tinysrp.h
+
+lib_LIBRARIES = libtinysrp.a
+
+CFLAGS = -O2 @signed@
+
+libtinysrp_a_SOURCES = \
+ tinysrp.c t_client.c t_getconf.c t_conv.c t_getpass.c t_sha.c t_math.c \
+ t_misc.c t_pw.c t_read.c t_server.c t_truerand.c \
+ bn_add.c bn_ctx.c bn_div.c bn_exp.c bn_mul.c bn_word.c bn_asm.c bn_lib.c \
+ bn_shift.c bn_sqr.c
+
+noinst_PROGRAMS = srvtest clitest
+srvtest_SOURCES = srvtest.c
+clitest_SOURCES = clitest.c
+
+bin_PROGRAMS = tconf tphrase
+tconf_SOURCES = tconf.c t_conf.c
+tphrase_SOURCES = tphrase.c
+
+LDADD = libtinysrp.a
+
+EXTRA_DIST = tpasswd Notes