summaryrefslogtreecommitdiff
path: root/openwrt/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/kernel')
-rw-r--r--openwrt/package/kernel/modules.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/package/kernel/modules.mk b/openwrt/package/kernel/modules.mk
index 51b7d8a..090945c 100644
--- a/openwrt/package/kernel/modules.mk
+++ b/openwrt/package/kernel/modules.mk
@@ -281,6 +281,13 @@ KCONFIG:=$(CONFIG_BRIDGE_NF_EBTABLES)
endef
$(eval $(call KernelPackage,ebtables))
+define KernelPackage/ipv6
+TITLE:=IPv6 support
+DESCRIPTION:=Kernel modules for IPv6 support
+KCONFIG:=$(CONFIG_IPV6)
+FILES:=$(MODULES_DIR)/kernel/net/ipv6/ipv6.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,ipv6))
define KernelPackage/ppp
TITLE:=PPP modules