summaryrefslogtreecommitdiff
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index 6a1bd95..437609a 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -73,6 +73,7 @@ $(BIN_DIR):
mkdir -p $(BIN_DIR)
$(INSTALL_TARGET_DIRS): lzma-loader-compile
+$(IMAGE_TARGETS): $(patsubst %,%-install,$(TARGET_DIRS))
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean