From 328d6b8fa26e189a18cbcf6f48ac2c2751e52ae5 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 2 Jul 2005 08:08:56 +0000
Subject: add a fix for mtd build with host gcc 4

SVN-Revision: 1315
---
 openwrt/target/linux/image/jffs2/Makefile               |  1 +
 openwrt/target/linux/image/jffs2/patches/gcc4-fix.patch | 12 ++++++++++++
 2 files changed, 13 insertions(+)
 create mode 100644 openwrt/target/linux/image/jffs2/patches/gcc4-fix.patch

(limited to 'openwrt/target')

diff --git a/openwrt/target/linux/image/jffs2/Makefile b/openwrt/target/linux/image/jffs2/Makefile
index 8734ee2..d5f03be 100644
--- a/openwrt/target/linux/image/jffs2/Makefile
+++ b/openwrt/target/linux/image/jffs2/Makefile
@@ -11,6 +11,7 @@ $(DL_DIR)/$(MTD_SOURCE):
 
 $(MTD_DIR)/.unpacked: $(DL_DIR)/$(MTD_SOURCE)
 	zcat $(DL_DIR)/$(MTD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+	$(PATCH) $(MTD_DIR) ./patches
 	touch $(MTD_DIR)/.unpacked
 
 $(MTD_DIR)/util/mkfs.jffs2: $(MTD_DIR)/.unpacked
diff --git a/openwrt/target/linux/image/jffs2/patches/gcc4-fix.patch b/openwrt/target/linux/image/jffs2/patches/gcc4-fix.patch
new file mode 100644
index 0000000..c7a274d
--- /dev/null
+++ b/openwrt/target/linux/image/jffs2/patches/gcc4-fix.patch
@@ -0,0 +1,12 @@
+diff -urN mtd-20050122.orig.old/include/mtd/jffs2-user.h mtd-20050122.orig.dev/include/mtd/jffs2-user.h
+--- mtd-20050122.orig.old/include/mtd/jffs2-user.h	2004-05-05 13:57:54.000000000 +0200
++++ mtd-20050122.orig.dev/include/mtd/jffs2-user.h	2005-07-02 10:03:09.000000000 +0200
+@@ -19,8 +19,6 @@
+ #undef je32_to_cpu
+ #undef jemode_to_cpu
+ 
+-extern int target_endian;
+-
+ #define t16(x) ({ uint16_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_16(__b); })
+ #define t32(x) ({ uint32_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_32(__b); })
+ 
-- 
cgit v1.1