summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-09-08 22:01:19 +0000
committerNicolas Thill <nico@openwrt.org>2005-09-08 22:01:19 +0000
commit3c6b5e928b353ab60ef2145df5ac0774f7b831ab (patch)
tree0989a9c3ae1610495bfad510d17427982da59c16 /openwrt/package/Makefile
parent54aa8c84c864bf2bd6d6e2a689f9129e4209efdc (diff)
downloadmtk-20170518-3c6b5e928b353ab60ef2145df5ac0774f7b831ab.zip
mtk-20170518-3c6b5e928b353ab60ef2145df5ac0774f7b831ab.tar.gz
mtk-20170518-3c6b5e928b353ab60ef2145df5ac0774f7b831ab.tar.bz2
add rrdtool1 (v1.0.x) and enable it by default, disable rrdtool (v1.2.x), change Maintainer in control files, tweak Makefiles
SVN-Revision: 1881
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index e078d18..cdc592b 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -135,6 +135,7 @@ package-$(BR2_PACKAGE_ROBOCFG) += robocfg
package-$(BR2_PACKAGE_RP_PPPOE) += rp-pppoe
package-$(BR2_PACKAGE_RRDCOLLECT) += rrdcollect
package-$(BR2_COMPILE_RRDTOOL) += rrdtool
+package-$(BR2_COMPILE_RRDTOOL1) += rrdtool1
package-$(BR2_PACKAGE_RSYNC) += rsync
package-$(BR2_PACKAGE_SABLEVM) += sablevm
package-$(BR2_PACKAGE_SABLEVM_CLASSPATH) += sablevm-classpath
@@ -230,8 +231,14 @@ portmap-compile: tcp_wrappers-compile
postgresql-compile: zlib-compile
ppp-compile: linux-atm-compile
quagga-compile: readline-compile ncurses-compile
+ifneq ($(BR2_PACKAGE_LIBRRD),)
rrdcollect-compile: rrdtool-compile
+endif
+ifneq ($(BR2_PACKAGE_LIBRRD1),)
+rrdcollect-compile: rrdtool1-compile
+endif
rrdtool-compile: cgilib-compile freetype-compile libart-compile libpng-compile
+rrdtool1-compile: zlib-compile
rsync-compile: popt-compile
samba-compile: cups-compile
screen-compile: ncurses-compile