summaryrefslogtreecommitdiff
path: root/openwrt/package/elhttp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/elhttp/Makefile
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadmtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/package/elhttp/Makefile')
-rw-r--r--openwrt/package/elhttp/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/openwrt/package/elhttp/Makefile b/openwrt/package/elhttp/Makefile
deleted file mode 100644
index 175f1db..0000000
--- a/openwrt/package/elhttp/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=elhttp
-PKG_VERSION:=0.22
-PKG_RELEASE:=1
-PKG_MD5SUM:=b52f68c47f709e9fc9429250eb8f954c
-
-PKG_SOURCE_URL:=http://phadej.daug.net/files/ \
- http://www.cr0.net:8040/code/network/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,ELHTTP,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
- $(MAKE) CC=$(TARGET_CC) CROSS=$(TARGET_CROSS) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- $(RSTRIP) $(PKG_INSTALL_DIR)/usr/sbin/
- touch $@
-
-$(IPKG_ELHTTP):
- mkdir -p $(IDIR_ELHTTP)
- $(CP) $(PKG_INSTALL_DIR)/* $(IDIR_ELHTTP)/
- $(RSTRIP) $(IDIR_ELHTTP)/
- $(IPKG_BUILD) $(IDIR_ELHTTP) $(PACKAGE_DIR)
-