summaryrefslogtreecommitdiff
path: root/openwrt/package/l2tpns/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/l2tpns/Makefile
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadmtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/package/l2tpns/Makefile')
-rw-r--r--openwrt/package/l2tpns/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/openwrt/package/l2tpns/Makefile b/openwrt/package/l2tpns/Makefile
deleted file mode 100644
index 278ecdd..0000000
--- a/openwrt/package/l2tpns/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=l2tpns
-PKG_VERSION:=2.1.14
-PKG_RELEASE:=1
-PKG_MD5SUM:=2a0ee2a3678160c335f1d68c17c4f871
-
-PKG_SOURCE_URL:=@SF/l2tpns
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,L2TPNS,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- LD=$(TARGET_CC) \
- OPTIM="$(TARGET_CFLAGS)" \
- DESTDIR=$(PKG_INSTALL_DIR) \
- STAGING_DIR=$(STAGING_DIR) \
- all install
- touch $@
-
-$(IPKG_L2TPNS):
- install -d -m0755 $(IDIR_L2TPNS)/etc/l2tpns
- $(CP) $(PKG_INSTALL_DIR)/etc/l2tpns/* $(IDIR_L2TPNS)/etc/l2tpns/
- install -d -m0755 $(IDIR_L2TPNS)/usr/lib/l2tpns
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tpns/* $(IDIR_L2TPNS)/usr/lib/l2tpns/
- install -d -m0755 $(IDIR_L2TPNS)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_L2TPNS)/usr/sbin/
- $(RSTRIP) $(IDIR_L2TPNS)
- $(IPKG_BUILD) $(IDIR_L2TPNS) $(PACKAGE_DIR)