summaryrefslogtreecommitdiff
path: root/openwrt/package/pptp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/pptp/Makefile
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadmtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/package/pptp/Makefile')
-rw-r--r--openwrt/package/pptp/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/openwrt/package/pptp/Makefile b/openwrt/package/pptp/Makefile
deleted file mode 100644
index 870341c..0000000
--- a/openwrt/package/pptp/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pptp
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=3
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
-
-PKG_SOURCE_URL:=@SF/pptpclient
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PPTP,pptp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- CFLAGS="$(TARGET_CFLAGS)" \
- all
- touch $@
-
-$(IPKG_PPTP):
- install -d -m0755 $(IDIR_PPTP)/sbin
- install -m0755 ./files/ifup.pptp $(IDIR_PPTP)/sbin/ifup.pptp
- install -d -m0755 $(IDIR_PPTP)/etc/ppp
- install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
- install -d -m0755 $(IDIR_PPTP)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/pptp $(IDIR_PPTP)/usr/sbin/
- $(RSTRIP) $(IDIR_PPTP)
- $(IPKG_BUILD) $(IDIR_PPTP) $(PACKAGE_DIR)