summaryrefslogtreecommitdiff
path: root/openwrt/package/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-30 20:22:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-30 20:22:21 +0000
commit1545f46b7695c13482a38b93a27297e95c9ff93a (patch)
tree63a46281f20de9677906658e2f82508ed41c1223 /openwrt/package/rules.mk
parentb3dc15de7869ed2816a95b84e2fb78ce1d9bd426 (diff)
downloadmtk-20170518-1545f46b7695c13482a38b93a27297e95c9ff93a.zip
mtk-20170518-1545f46b7695c13482a38b93a27297e95c9ff93a.tar.gz
mtk-20170518-1545f46b7695c13482a38b93a27297e95c9ff93a.tar.bz2
manually compile packages without having the config setting active if environment variable DEVELOPER is set
SVN-Revision: 1113
Diffstat (limited to 'openwrt/package/rules.mk')
-rw-r--r--openwrt/package/rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index 03b750f..1ca03b7 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -6,6 +6,9 @@ INFO_$(1):=$(IPKG_STATE_DIR)/info/$(2).list
ifneq ($(BR2_PACKAGE_$(1)),)
compile: $$(IPKG_$(1))
endif
+ifneq ($(DEVELOPER),)
+compile: $$(IPKG_$(1))
+endif
ifeq ($(BR2_PACKAGE_$(1)),y)
install: $$(INFO_$(1))
endif