summaryrefslogtreecommitdiff
path: root/openwrt/package/vsftpd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/vsftpd/Makefile
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadmtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/package/vsftpd/Makefile')
-rw-r--r--openwrt/package/vsftpd/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/openwrt/package/vsftpd/Makefile b/openwrt/package/vsftpd/Makefile
deleted file mode 100644
index d3c72c8..0000000
--- a/openwrt/package/vsftpd/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.4
-PKG_RELEASE:=1
-PKG_MD5SUM:=c0bf8c7b8e15ab15827172786fc56115
-
-PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,VSFTPD,vsftpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- vsftpd install
- touch $@
-
-$(IPKG_VSFTPD):
- install -d -m0755 $(IDIR_VSFTPD)/etc
- install -m0644 ./files/vsftpd.conf $(IDIR_VSFTPD)/etc/vsftpd.conf
- install -d -m0755 $(IDIR_VSFTPD)/etc/init.d
- install -m0755 ./files/vsftpd.init $(IDIR_VSFTPD)/etc/init.d/vsftpd
- install -d -m0755 $(IDIR_VSFTPD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/vsftpd $(IDIR_VSFTPD)/usr/sbin/
- $(RSTRIP) $(IDIR_VSFTPD)
- $(IPKG_BUILD) $(IDIR_VSFTPD) $(PACKAGE_DIR)