summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/ar7/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-12 13:59:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-12 13:59:13 +0000
commit6c3d9c2ca8ef0dfb084b82915f772d450952dbff (patch)
tree72e58776dc3943395f52c3058cc9ee96565a7eb0 /openwrt/target/linux/image/ar7/Makefile
parent544736f3e2728ad11c3804003d07856f1aec3b6f (diff)
downloadmtk-20170518-6c3d9c2ca8ef0dfb084b82915f772d450952dbff.zip
mtk-20170518-6c3d9c2ca8ef0dfb084b82915f772d450952dbff.tar.gz
mtk-20170518-6c3d9c2ca8ef0dfb084b82915f772d450952dbff.tar.bz2
add pspboot support, cleanup in ar7 board support
SVN-Revision: 1611
Diffstat (limited to 'openwrt/target/linux/image/ar7/Makefile')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index ee2b570..1d1aea7 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -64,14 +64,15 @@ $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-ar7-2.4-kernel.bi
define pattern_template
$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin
(dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin) | \
- $(STAGING_DIR)/bin/addpattern -p $(1) -o $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
-
+ $(STAGING_DIR)/bin/addpattern -p $(1) $(2) -o $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
+
install: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
endef
$(eval $(call pattern_template,WA22))
$(eval $(call pattern_template,WAG2))
$(eval $(call pattern_template,WA21))
+$(eval $(call pattern_template,WA32,-b))
clean:
rm -rf $(PKG_BUILD_DIR)