summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/brcm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 18:55:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 18:55:48 +0000
commit3f06c9bcf2b564317d891df3fe5b41050719cd91 (patch)
treebe92aa7ae001cbfc0824b5eff5acb5c615c8025a /openwrt/target/linux/image/brcm/Makefile
parent863218d0a27261f90d946683618c04f243cf3870 (diff)
downloadmtk-20170518-3f06c9bcf2b564317d891df3fe5b41050719cd91.zip
mtk-20170518-3f06c9bcf2b564317d891df3fe5b41050719cd91.tar.gz
mtk-20170518-3f06c9bcf2b564317d891df3fe5b41050719cd91.tar.bz2
add missing piece from whiterussian image building makefile to trunk/
SVN-Revision: 2250
Diffstat (limited to 'openwrt/target/linux/image/brcm/Makefile')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index 73d236a..31f941f 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -25,8 +25,13 @@ endif
ifeq ($(FS),jffs2-4MB)
TRXALIGN:=-a 0x10000
endif
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
- $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+
+$(KDIR)/loader.tmp.gz:
+ cp $(BUILD_DIR)/loader.gz $@
+ echo -ne "\\x00" >> $@
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/loader.tmp.gz
+ $(STAGING_DIR)/bin/trx -o $@ $(KDIR)/loader.tmp.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
ifeq ($(KERNEL),2.6)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))