summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/brcm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-11 21:18:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-11 21:18:26 +0000
commit4c659f618c83aa8ef850cf24e6f240e0aeb0f598 (patch)
tree8813ca5ad209754da7f4b71014c7a131ee200196 /openwrt/target/linux/image/brcm/Makefile
parentc90793463c2602b951b71d629a6530bab2be50d0 (diff)
downloadmtk-20170518-4c659f618c83aa8ef850cf24e6f240e0aeb0f598.zip
mtk-20170518-4c659f618c83aa8ef850cf24e6f240e0aeb0f598.tar.gz
mtk-20170518-4c659f618c83aa8ef850cf24e6f240e0aeb0f598.tar.bz2
cleanup in target/
SVN-Revision: 1205
Diffstat (limited to 'openwrt/target/linux/image/brcm/Makefile')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
new file mode 100644
index 0000000..2cff6af
--- /dev/null
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -0,0 +1,47 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-brcm
+
+lzma-loader-clean:
+ $(MAKE) -C lzma-loader clean
+
+lzma-loader-prepare:
+ $(MAKE) -C lzma-loader prepare
+
+lzma-loader-compile: lzma-loader-prepare
+ $(MAKE) -C lzma-loader compile
+
+$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
+ cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
+
+$(BIN_DIR)/openwrt-brcm-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma
+ $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(KDIR)/root.$(FS)
+
+ifeq ($(KERNEL),2.4)
+FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+
+ifneq ($(FS),jffs2-8MB)
+$(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin: $(BIN_DIR)/openwrt-brcm-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/addpattern -2 -i $< -o $@ -g
+ $(SED) "1s,^W54S,W54G," $@
+
+install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin
+endif
+
+ifneq ($(FS),jffs2-4MB)
+$(BIN_DIR)/openwrt-wrt54gs-$(FSNAME).bin: $(BIN_DIR)/openwrt-brcm-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/addpattern -2 -i $< -o $@ -g
+
+install: $(BIN_DIR)/openwrt-wrt54gs-$(FSNAME).bin
+endif
+
+$(BIN_DIR)/openwrt-motorola-$(FS).bin: $(BIN_DIR)/openwrt-brcm-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/motorola-bin $< $@
+install: $(BIN_DIR)/openwrt-motorola-$(FS).bin
+endif
+
+clean: lzma-loader-clean
+prepare: lzma-loader-prepare
+compile: lzma-loader-compile
+install: $(BIN_DIR)/openwrt-brcm-$(KERNEL)-$(FS).trx
+