summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/brcm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-14 20:31:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-14 20:31:12 +0000
commitbcd56256b20d28c62144dd2bdb36e9d811b968ac (patch)
tree636813efcb2f3624fea8bcbd1e2437f81b97224c /openwrt/target/linux/image/brcm/Makefile
parent2d72780bd34817e392a0071747cac1026abace03 (diff)
downloadmtk-20170518-bcd56256b20d28c62144dd2bdb36e9d811b968ac.zip
mtk-20170518-bcd56256b20d28c62144dd2bdb36e9d811b968ac.tar.gz
mtk-20170518-bcd56256b20d28c62144dd2bdb36e9d811b968ac.tar.bz2
fix lzma loader dependency
SVN-Revision: 1674
Diffstat (limited to 'openwrt/target/linux/image/brcm/Makefile')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index f551b84..c0c83c5 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -15,7 +15,7 @@ ifeq ($(IB),)
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma compile
endif
ifeq ($(FS),jffs2-8MB)
@@ -54,13 +54,12 @@ ifeq ($(IB),)
clean: lzma-loader-clean
prepare: lzma-loader-prepare
compile: lzma-loader-compile
-install: compile $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
else
clean:
prepare:
compile:
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
endif
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
install-ib:
mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
cp -dpR $(STAGING_DIR)/bin/addpattern $(STAGING_DIR)/bin/trx $(STAGING_DIR)/bin/motorola-bin $(IB_DIR)/staging_dir_$(ARCH)/bin