summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/jffs2.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/target/linux/image/jffs2.mk
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadmtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/target/linux/image/jffs2.mk')
-rw-r--r--openwrt/target/linux/image/jffs2.mk46
1 files changed, 0 insertions, 46 deletions
diff --git a/openwrt/target/linux/image/jffs2.mk b/openwrt/target/linux/image/jffs2.mk
deleted file mode 100644
index 281db01..0000000
--- a/openwrt/target/linux/image/jffs2.mk
+++ /dev/null
@@ -1,46 +0,0 @@
-ifneq ($(BR2_BIG_ENDIAN),y)
-JFFS2OPTS := --pad --little-endian --squash
-else
-JFFS2OPTS := --pad --big-endian --squash
-endif
-
-#JFFS2OPTS += -Xlzo -msize -Xlzari
-
-jffs2-prepare:
- $(MAKE) -C jffs2 prepare $(MAKE_TRACE)
-
-jffs2-compile: prepare-targets
- $(MAKE) -C jffs2 compile $(MAKE_TRACE)
-
-jffs2-clean:
- $(MAKE) -C jffs2 clean $(MAKE_TRACE)
- rm -f $(KDIR)/root.jffs2*
-
-$(KDIR)/root.jffs2-4MB: install-prepare
- @rm -rf $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $@ -d $(KDIR)/root $(MAKE_TRACE)
-
-$(KDIR)/root.jffs2-8MB: install-prepare
- @rm -rf $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $@ -d $(KDIR)/root $(MAKE_TRACE)
-
-ifeq ($(IB),)
-jffs2-install: compile-targets $(BOARD)-compile
-endif
-
-jffs2-install: $(KDIR)/root.jffs2-4MB $(KDIR)/root.jffs2-8MB
- $(TRACE) target/linux/image/$(BOARD)/install
- $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="jffs2-4MB"
- $(TRACE) target/linux/image/$(BOARD)/install
- $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="jffs2-8MB"
-
-jffs2-install-ib: compile-targets
- mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
- $(CP) $(STAGING_DIR)/bin/mkfs.jffs2 $(IB_DIR)/staging_dir_$(ARCH)/bin
-
-prepare-targets: jffs2-prepare
-compile-targets: jffs2-compile
-install-targets: jffs2-install
-install-ib: jffs2-install-ib
-clean-targets: jffs2-clean
-