summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/target/linux/image/squashfs.mk
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadmtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
mtk-20170518-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk37
1 files changed, 0 insertions, 37 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
deleted file mode 100644
index 9d344ba..0000000
--- a/openwrt/target/linux/image/squashfs.mk
+++ /dev/null
@@ -1,37 +0,0 @@
-ifneq ($(BR2_BIG_ENDIAN),y)
-endian := le
-else
-endian := be
-endif
-
-squashfs-prepare:
- $(MAKE) -C squashfs prepare $(MAKE_TRACE)
-
-squashfs-compile: prepare-targets
- $(MAKE) -C squashfs compile $(MAKE_TRACE)
-
-squashfs-clean:
- $(MAKE) -C squashfs clean $(MAKE_TRACE)
- rm -f $(KDIR)/root.squashfs
-
-$(KDIR)/root.squashfs: install-prepare
- @mkdir -p $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -$(endian) $(MAKE_TRACE)
-
-ifeq ($(IB),)
-squashfs-install: compile-targets $(BOARD)-compile
-endif
-
-squashfs-install: $(KDIR)/root.squashfs
- $(TRACE) target/linux/image/$(BOARD)/install
- $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
-
-squashfs-install-ib: compile-targets
- mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
- $(CP) $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
-
-prepare-targets: squashfs-prepare
-compile-targets: squashfs-compile
-install-targets: squashfs-install
-install-ib: squashfs-install-ib
-clean: squashfs-clean