summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/x86-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-01-10 19:43:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-01-10 19:43:00 +0000
commitea35a1edbebfa01ee51e625e670a65fa985fc1b5 (patch)
treedbdaf951693481c46030073d2fe14fe6b87b2d88 /openwrt/target/linux/x86-2.4/Makefile
parent60cc7e45d753052032679a2ce4f4e323ee1da8f6 (diff)
downloadmtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.zip
mtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.tar.gz
mtk-20170518-ea35a1edbebfa01ee51e625e670a65fa985fc1b5.tar.bz2
large target/linux cleanup
SVN-Revision: 2877
Diffstat (limited to 'openwrt/target/linux/x86-2.4/Makefile')
-rw-r--r--openwrt/target/linux/x86-2.4/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/openwrt/target/linux/x86-2.4/Makefile b/openwrt/target/linux/x86-2.4/Makefile
new file mode 100644
index 0000000..97ded84
--- /dev/null
+++ b/openwrt/target/linux/x86-2.4/Makefile
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.4.32
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+
+include ../rules.mk
+include ./config
+
+$(eval $(call KMOD_template,WD1100,wd1100,\
+ $(MODULES_DIR)/kernel/drivers/char/wd1100.o \
+,CONFIG_WD1100))
+
+
+include ../generic-$(KERNEL)/modules.mk
+include ../kernel.mk
+
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
+ @cp config $(LINUX_DIR)/.config
+ touch $@
+
+$(LINUX_BUILD_DIR)/bzImage: $(LINUX_DIR)/vmlinux
+ $(MAKE) -C $(LINUX_DIR) TOPDIR=$(LINUX_DIR) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) bzImage $(MAKE_TRACE)
+ cp -f $(LINUX_DIR)/arch/i386/boot/bzImage $@
+ touch $@
+
+compile: $(LINUX_BUILD_DIR)/bzImage