summaryrefslogtreecommitdiff
path: root/openwrt/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-27 13:30:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-27 13:30:10 +0000
commit138fee69d1146783d97eed8a4fbd26c1a7e6930d (patch)
treef702419ca641f18c50d00a937c3a18d9f97cea33 /openwrt/toolchain
parent60d16281109b5c71b59b713b2d8fee59a54f99be (diff)
downloadmtk-20170518-138fee69d1146783d97eed8a4fbd26c1a7e6930d.zip
mtk-20170518-138fee69d1146783d97eed8a4fbd26c1a7e6930d.tar.gz
mtk-20170518-138fee69d1146783d97eed8a4fbd26c1a7e6930d.tar.bz2
add cflags to uClibc compile
SVN-Revision: 1770
Diffstat (limited to 'openwrt/toolchain')
-rw-r--r--openwrt/toolchain/uClibc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/toolchain/uClibc/Makefile b/openwrt/toolchain/uClibc/Makefile
index d40d8c6..e5f8d44 100644
--- a/openwrt/toolchain/uClibc/Makefile
+++ b/openwrt/toolchain/uClibc/Makefile
@@ -67,6 +67,7 @@ endif
DEVEL_PREFIX=/usr/ \
RUNTIME_PREFIX=$(TOOL_BUILD_DIR)/uClibc_dev/ \
HOSTCC="$(HOSTCC)" \
+ CPU_CFLAGS="$(TARGET_CFLAGS)" \
pregen install_dev;
touch $(UCLIBC_DIR)/.configured
@@ -76,6 +77,7 @@ $(UCLIBC_DIR)/lib/libc.a: $(UCLIBC_DIR)/.configured $(LIBFLOAT_TARGET)
DEVEL_PREFIX=/ \
RUNTIME_PREFIX=/ \
HOSTCC="$(HOSTCC)" \
+ CPU_CFLAGS="$(TARGET_CFLAGS)" \
all
touch -c $(UCLIBC_DIR)/lib/libc.a