summaryrefslogtreecommitdiff
path: root/openwrt/package/6tunnel
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/6tunnel')
-rw-r--r--openwrt/package/6tunnel/Config.in12
-rw-r--r--openwrt/package/6tunnel/Makefile60
-rw-r--r--openwrt/package/6tunnel/ipkg/6tunnel.control5
3 files changed, 0 insertions, 77 deletions
diff --git a/openwrt/package/6tunnel/Config.in b/openwrt/package/6tunnel/Config.in
deleted file mode 100644
index 614498b..0000000
--- a/openwrt/package/6tunnel/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_6TUNNEL
- prompt "6tunnel........................... IPv4 / IPv6 tunnel proxy"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_KMOD_IPV6
- help
- 6tunnel allows you to use services provided by IPv6 hosts with IPv4-only
- applications and vice-versa. It can bind to any of your IPv4 (default)
- or IPv6 addresses and forward all data to IPv4 or IPv6 (default) host.
-
- http://toxygen.net/6tunnel/
-
diff --git a/openwrt/package/6tunnel/Makefile b/openwrt/package/6tunnel/Makefile
deleted file mode 100644
index 8b24d7b..0000000
--- a/openwrt/package/6tunnel/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=6tunnel
-PKG_VERSION:=0.11rc1
-PKG_RELEASE:=1
-PKG_MD5SUM:=b325fa9d238e32195fbb3fc3646b0d28
-
-PKG_SOURCE_URL:=http://toxygen.net/6tunnel/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-0.11
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,6TUNNEL,6tunnel,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ac_cv_path_STRIP=$(STRIP) \
- ac_cv_func_vsnprintf=yes \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/sbin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- default
- touch $@
-
-$(IPKG_6TUNNEL):
- install -d -m0755 $(IDIR_6TUNNEL)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/6tunnel $(IDIR_6TUNNEL)/usr/sbin/
- $(RSTRIP) $(IDIR_6TUNNEL)/
- $(IPKG_BUILD) $(IDIR_6TUNNEL) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/6tunnel/ipkg/6tunnel.control b/openwrt/package/6tunnel/ipkg/6tunnel.control
deleted file mode 100644
index ce63bd8..0000000
--- a/openwrt/package/6tunnel/ipkg/6tunnel.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: 6tunnel
-Priority: optional
-Section: net
-Depends:
-Description: An IPv4/IPv6 tunnel proxy