summaryrefslogtreecommitdiff
path: root/openwrt/package/cgilib
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/cgilib')
-rw-r--r--openwrt/package/cgilib/Config.in12
-rw-r--r--openwrt/package/cgilib/Makefile50
-rw-r--r--openwrt/package/cgilib/ipkg/cgilib.control7
-rw-r--r--openwrt/package/cgilib/patches/100-shared_lib.patch41
-rw-r--r--openwrt/package/cgilib/patches/200-cgitest_bugfix.patch11
5 files changed, 0 insertions, 121 deletions
diff --git a/openwrt/package/cgilib/Config.in b/openwrt/package/cgilib/Config.in
deleted file mode 100644
index 23364d1..0000000
--- a/openwrt/package/cgilib/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_CGILIB
- prompt "cgilib............................ Simple CGI Library"
- tristate
-# default m if CONFIG_DEVEL
- default n
- help
- This library provides a simple programming API to the Common Gateway
- Interface (CGI). It features HTTP Redirect, provides read access to
- FORM variables, sets HTTP Cookies and reads them.
-
- http://www.infodrom.org/projects/cgilib/
-
diff --git a/openwrt/package/cgilib/Makefile b/openwrt/package/cgilib/Makefile
deleted file mode 100644
index b81effd..0000000
--- a/openwrt/package/cgilib/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=cgilib
-PKG_VERSION:=0.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=5187ba11b2ec165b6c5b6629087733b0
-
-PKG_SOURCE_URL:=http://www.infodrom.org/projects/cgilib/download
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,CGILIB,cgilib,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- OFLAGS="$(TARGET_CFLAGS)" \
- all
- touch $@
-
-$(IPKG_CGILIB):
- install -d -m0755 $(IDIR_CGILIB)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libcgi.so.* $(IDIR_CGILIB)/usr/lib/
- $(RSTRIP) $(IDIR_CGILIB)
- $(IPKG_BUILD) $(IDIR_CGILIB) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libcgi.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_BUILD_DIR)/cgi.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libcgi.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libcgi.so
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/cgi.h \
- $(STAGING_DIR)/usr/lib/libcgi.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/cgilib/ipkg/cgilib.control b/openwrt/package/cgilib/ipkg/cgilib.control
deleted file mode 100644
index eeed8be..0000000
--- a/openwrt/package/cgilib/ipkg/cgilib.control
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: cgilib
-Priority: optional
-Section: libs
-Description: Simple CGI Library.
- This library provides a simple programming API to the Common Gateway
- Interface (CGI). It features HTTP Redirect, provides read access to
- FORM variables, sets HTTP Cookies and reads them.
diff --git a/openwrt/package/cgilib/patches/100-shared_lib.patch b/openwrt/package/cgilib/patches/100-shared_lib.patch
deleted file mode 100644
index 5603340..0000000
--- a/openwrt/package/cgilib/patches/100-shared_lib.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -ruN cgilib-0.5-orig/Makefile cgilib-0.5-1/Makefile
---- cgilib-0.5-orig/Makefile 1999-08-20 23:14:07.000000000 +0200
-+++ cgilib-0.5-1/Makefile 2005-08-10 20:28:17.000000000 +0200
-@@ -14,14 +14,26 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
-
--CFLAGS = -I. -Wall -O2 -g
-+OFLAGS = -O2 -g
-+CFLAGS = -I. -Wall $(OFLAGS)
- LDFLAGS = -L.
- LIBS = -lcgi
-
-+SOVER_MAJ := 0
-+SOVER_MIN := 0
-+SOVER_REV := 0
-+SONAME := libcgi.so.$(SOVER_MAJ)
-+SOREAL := libcgi.so.$(SOVER_MAJ).$(SOVER_MIN).$(SOVER_REV)
-+
- OBJS = cgi.o cookies.o
-
- libcgi.a: $(OBJS)
-- ar rc $@ $^
-+ $(AR) rc $@ $^
-+
-+libcgi.so: $(OBJS)
-+ $(CC) -shared -o $(SOREAL) $(LDFLAGS) -Wl,-soname,$(SONAME) $^
-+ ln -sf $(SOREAL) $(SONAME)
-+ ln -sf $(SONAME) libcgi.so
-
- cgitest: cgitest.o libcgi.a
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
-@@ -29,7 +41,7 @@
- jumpto: jumpto.o libcgi.a
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
-
--all: libcgi.a cgitest jumpto
-+all: libcgi.a libcgi.so cgitest jumpto
-
- install: cgitest
- install -m 755 cgitest /usr/lib/cgi-bin
diff --git a/openwrt/package/cgilib/patches/200-cgitest_bugfix.patch b/openwrt/package/cgilib/patches/200-cgitest_bugfix.patch
deleted file mode 100644
index 62a68e7..0000000
--- a/openwrt/package/cgilib/patches/200-cgitest_bugfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cgilib-0.5/cgitest.c.orig 1999-08-17 15:21:20.000000000 +0200
-+++ cgilib-0.5/cgitest.c 2005-08-10 20:49:01.000000000 +0200
-@@ -113,7 +113,7 @@
- cgiHeader();
- printf ("<html>\n<head><title>cgilib</title></title>\n\n<body bgcolor=\"#ffffff\">\n");
- printf ("<h1><a href=\"%s\">cgilib</a></h1>\n", URL);
-- printf ("<h3>Cookie "Library" set</h3>\n");
-+ printf ("<h3>Cookie \"Library\" set</h3>\n");
- printf ("<p><br><p><br><a href=\"/cgi-bin/cgitest\">Test</a><p>\n");
- printf ("<p><br><p><br><a href=\"/cgi-bin/cgitest/redirect\">Redirect</a><p>\n");
- printf ("<p><br><p><br><a href=\"/cgi-bin/cgitest/listall\">List Everything</a><p>\n");