summaryrefslogtreecommitdiff
path: root/openwrt/package/chillispot
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/chillispot')
-rw-r--r--openwrt/package/chillispot/Config.in16
-rw-r--r--openwrt/package/chillispot/Makefile73
-rw-r--r--openwrt/package/chillispot/files/chillispot.init20
-rw-r--r--openwrt/package/chillispot/ipkg/chillispot.conffiles1
-rw-r--r--openwrt/package/chillispot/ipkg/chillispot.control5
5 files changed, 0 insertions, 115 deletions
diff --git a/openwrt/package/chillispot/Config.in b/openwrt/package/chillispot/Config.in
deleted file mode 100644
index 34ffc6e..0000000
--- a/openwrt/package/chillispot/Config.in
+++ /dev/null
@@ -1,16 +0,0 @@
-config BR2_PACKAGE_CHILLISPOT
- prompt "chillispot........................ Wireless LAN access point controller"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_KMOD_TUN
- help
- ChilliSpot is an open source captive portal or wireless LAN
- access point controller. It is used for authenticating users
- of a wireless LAN. It supports web based login which is today's
- standard for public HotSpots and it supports Wireless Protected
- Access (WPA) which is the standard of the future. Authentication,
- authorization and accounting (AAA) is handled by your favorite
- radius server.
-
- http://www.chillispot.org/
-
diff --git a/openwrt/package/chillispot/Makefile b/openwrt/package/chillispot/Makefile
deleted file mode 100644
index 1d63236..0000000
--- a/openwrt/package/chillispot/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=chillispot
-PKG_VERSION:=1.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=997827a9302a85920cfbc1334092ac0c
-
-PKG_SOURCE_URL:=http://www.chillispot.org/download
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,CHILLISPOT,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ac_cv_func_malloc_0_nonnull=yes \
- ac_cv_func_memcmp_working=yes \
- ac_cv_func_setvbuf_reversed=no \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- --with-gnu-ld \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_CHILLISPOT):
- install -m0755 -d $(IDIR_CHILLISPOT)/etc/init.d
- install -m0755 ./files/$(PKG_NAME).init $(IDIR_CHILLISPOT)/etc/init.d/chilli
- install -m0755 -d $(IDIR_CHILLISPOT)/etc
- install -m0644 $(PKG_BUILD_DIR)/doc/chilli.conf $(IDIR_CHILLISPOT)/etc/
- install -m0755 -d $(IDIR_CHILLISPOT)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/chilli $(IDIR_CHILLISPOT)/usr/sbin/
- $(RSTRIP) $(IDIR_CHILLISPOT)
- $(IPKG_BUILD) $(IDIR_CHILLISPOT) $(PACKAGE_DIR)
diff --git a/openwrt/package/chillispot/files/chillispot.init b/openwrt/package/chillispot/files/chillispot.init
deleted file mode 100644
index 289b1fe..0000000
--- a/openwrt/package/chillispot/files/chillispot.init
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-RUN_D=/var/run
-PID_F=$RUN_D/chilli.pid
-
-case $1 in
- start)
- /sbin/insmod tun >/dev/null 2>&1
- [ -d $RUN_D ] || mkdir -p $RUN_D
- /usr/sbin/chilli
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-
-exit $?
diff --git a/openwrt/package/chillispot/ipkg/chillispot.conffiles b/openwrt/package/chillispot/ipkg/chillispot.conffiles
deleted file mode 100644
index 0848516..0000000
--- a/openwrt/package/chillispot/ipkg/chillispot.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/chilli.conf
diff --git a/openwrt/package/chillispot/ipkg/chillispot.control b/openwrt/package/chillispot/ipkg/chillispot.control
deleted file mode 100644
index 0bb2bad..0000000
--- a/openwrt/package/chillispot/ipkg/chillispot.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: chillispot
-Priority: optional
-Section: net
-Depends: kmod-tun
-Description: ChilliSpot is a Wireless LAN Access Point Controller.