summaryrefslogtreecommitdiff
path: root/openwrt/package/dropbear
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/dropbear')
-rw-r--r--openwrt/package/dropbear/Config.in14
-rw-r--r--openwrt/package/dropbear/Makefile94
-rwxr-xr-xopenwrt/package/dropbear/files/S50dropbear16
-rw-r--r--openwrt/package/dropbear/ipkg/dropbear.control4
-rw-r--r--openwrt/package/dropbear/ipkg/dropbearconvert.control5
-rw-r--r--openwrt/package/dropbear/patches/100-pubkey_path.patch45
-rw-r--r--openwrt/package/dropbear/patches/110-change_user.patch19
-rw-r--r--openwrt/package/dropbear/patches/120-hostkey_prompt.patch12
-rw-r--r--openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch22
-rw-r--r--openwrt/package/dropbear/patches/140-use_dev_urandom.patch12
-rw-r--r--openwrt/package/dropbear/patches/150-dbconvert_standalone.patch14
11 files changed, 0 insertions, 257 deletions
diff --git a/openwrt/package/dropbear/Config.in b/openwrt/package/dropbear/Config.in
deleted file mode 100644
index efdc70b..0000000
--- a/openwrt/package/dropbear/Config.in
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_DROPBEAR
- prompt "dropbear.......................... Small SSH 2 client/server"
- tristate
- default y
- help
- A small SSH 2 server/client designed for small memory environments.
-
- http://matt.ucc.asn.au/dropbear/
-
-config BR2_PACKAGE_DBCONVERT
- prompt "dropbearconvert................. Utility for converting SSH keys"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_DROPBEAR
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
deleted file mode 100644
index 75eaf6e..0000000
--- a/openwrt/package/dropbear/Makefile
+++ /dev/null
@@ -1,94 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=dropbear
-PKG_VERSION:=0.48.1
-PKG_RELEASE:=1
-PKG_MD5SUM:=ca8e53a766faec831882831364568421
-
-PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,DROPBEAR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,DBCONVERT,dropbearconvert,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
- $(SED) 's,^#define DO_HOST_LOOKUP,/* & */,g' $(PKG_BUILD_DIR)/options.h
- (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
- autoconf; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --with-shared \
- --disable-pam \
- --enable-openpty \
- --enable-syslog \
- --disable-shadow \
- --disable-lastlog \
- --disable-utmp \
- --disable-utmpx \
- --disable-wtmp \
- --disable-wtmpx \
- --disable-loginfunc \
- --disable-pututline \
- --disable-pututxline \
- --disable-zlib \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- LD=$(TARGET_CC) \
- PROGRAMS="dropbear dbclient dropbearkey scp" \
- MULTI=1 SCPPROGRESS=1
- $(MAKE) -C $(PKG_BUILD_DIR) \
- LD=$(TARGET_CC) \
- PROGRAMS="dropbearconvert"
- touch $@
-
-$(IPKG_DBCONVERT):
- mkdir -p $(IDIR_DBCONVERT)/usr/bin
- install -m 755 $(PKG_BUILD_DIR)/dropbearconvert \
- $(IDIR_DBCONVERT)/usr/bin/dropbearconvert
- $(IPKG_BUILD) $(IDIR_DBCONVERT) $(PACKAGE_DIR)
-
-$(IPKG_DROPBEAR):
- mkdir -p $(IDIR_DROPBEAR)/usr/bin
- mkdir -p $(IDIR_DROPBEAR)/usr/sbin
- install -m 755 $(PKG_BUILD_DIR)/dropbearmulti \
- $(IDIR_DROPBEAR)/usr/sbin/dropbear
- $(STRIP) $(IDIR_DROPBEAR)/usr/sbin/dropbear
- ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/scp
- ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/ssh
- ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dbclient
- ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearkey
- mkdir -p $(IDIR_DROPBEAR)/etc/init.d
- install -m 755 ./files/S50dropbear $(IDIR_DROPBEAR)/etc/init.d/
- $(IPKG_BUILD) $(IDIR_DROPBEAR) $(PACKAGE_DIR)
diff --git a/openwrt/package/dropbear/files/S50dropbear b/openwrt/package/dropbear/files/S50dropbear
deleted file mode 100755
index 88fc288..0000000
--- a/openwrt/package/dropbear/files/S50dropbear
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-for type in rsa dss; do {
- # check for keys
- key=/etc/dropbear/dropbear_${type}_host_key
- [ ! -f $key ] && {
- # generate missing keys
- mkdir -p /etc/dropbear
- [ -x /usr/bin/dropbearkey ] && {
- /usr/bin/dropbearkey -t $type -f $key 2>&- >&- && exec $0 $*
- } &
- exit 0
- }
-}; done
-
-/usr/sbin/dropbear
diff --git a/openwrt/package/dropbear/ipkg/dropbear.control b/openwrt/package/dropbear/ipkg/dropbear.control
deleted file mode 100644
index 0aa8cc5..0000000
--- a/openwrt/package/dropbear/ipkg/dropbear.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: dropbear
-Priority: optional
-Section: net
-Description: a small SSH 2 server/client designed for small memory environments.
diff --git a/openwrt/package/dropbear/ipkg/dropbearconvert.control b/openwrt/package/dropbear/ipkg/dropbearconvert.control
deleted file mode 100644
index 9dd5ecd..0000000
--- a/openwrt/package/dropbear/ipkg/dropbearconvert.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: dropbearconvert
-Priority: optional
-Depends: zlib
-Section: net
-Description: Utility for converting SSH keys
diff --git a/openwrt/package/dropbear/patches/100-pubkey_path.patch b/openwrt/package/dropbear/patches/100-pubkey_path.patch
deleted file mode 100644
index cbe525b..0000000
--- a/openwrt/package/dropbear/patches/100-pubkey_path.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- dropbear.old/svr-authpubkey.c.orig 2006-06-03 14:54:43.000000000 +0000
-+++ dropbear.dev/svr-authpubkey.c 2006-06-03 15:03:19.000000000 +0000
-@@ -176,6 +176,8 @@
- goto out;
- }
-
-+ if (ses.authstate.pw->pw_uid != 0) {
-+
- /* we don't need to check pw and pw_dir for validity, since
- * its been done in checkpubkeyperms. */
- len = strlen(ses.authstate.pw->pw_dir);
-@@ -187,6 +189,9 @@
-
- /* open the file */
- authfile = fopen(filename, "r");
-+ } else {
-+ authfile = fopen("/etc/dropbear/authorized_keys","r");
-+ }
- if (authfile == NULL) {
- goto out;
- }
-@@ -274,6 +279,8 @@
- goto out;
- }
-
-+ if (ses.authstate.pw->pw_uid != 0) {
-+
- /* allocate max required pathname storage,
- * = path + "/.ssh/authorized_keys" + '\0' = pathlen + 22 */
- filename = m_malloc(len + 22);
-@@ -295,6 +302,14 @@
- if (checkfileperm(filename) != DROPBEAR_SUCCESS) {
- goto out;
- }
-+ } else {
-+ if (checkfileperm("/etc/dropbear") != DROPBEAR_SUCCESS) {
-+ goto out;
-+ }
-+ if (checkfileperm("/etc/dropbear/authorized_keys") != DROPBEAR_SUCCESS) {
-+ goto out;
-+ }
-+ }
-
- /* file looks ok, return success */
- ret = DROPBEAR_SUCCESS;
diff --git a/openwrt/package/dropbear/patches/110-change_user.patch b/openwrt/package/dropbear/patches/110-change_user.patch
deleted file mode 100644
index ac617e2..0000000
--- a/openwrt/package/dropbear/patches/110-change_user.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -urN dropbear.old/svr-chansession.c dropbear.dev/svr-chansession.c
---- dropbear.old/svr-chansession.c 2005-12-09 06:42:33.000000000 +0100
-+++ dropbear.dev/svr-chansession.c 2005-12-12 01:42:38.982034750 +0100
-@@ -860,12 +860,12 @@
- /* We can only change uid/gid as root ... */
- if (getuid() == 0) {
-
-- if ((setgid(ses.authstate.pw->pw_gid) < 0) ||
-+ if ((ses.authstate.pw->pw_gid != 0) && ((setgid(ses.authstate.pw->pw_gid) < 0) ||
- (initgroups(ses.authstate.pw->pw_name,
-- ses.authstate.pw->pw_gid) < 0)) {
-+ ses.authstate.pw->pw_gid) < 0))) {
- dropbear_exit("error changing user group");
- }
-- if (setuid(ses.authstate.pw->pw_uid) < 0) {
-+ if ((ses.authstate.pw->pw_uid != 0) && (setuid(ses.authstate.pw->pw_uid) < 0)) {
- dropbear_exit("error changing user");
- }
- } else {
diff --git a/openwrt/package/dropbear/patches/120-hostkey_prompt.patch b/openwrt/package/dropbear/patches/120-hostkey_prompt.patch
deleted file mode 100644
index 59639e7..0000000
--- a/openwrt/package/dropbear/patches/120-hostkey_prompt.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN dropbear-0.45.old/cli-kex.c dropbear-0.45/cli-kex.c
---- dropbear-0.45.old/cli-kex.c 2005-03-07 05:27:01.000000000 +0100
-+++ dropbear-0.45/cli-kex.c 2005-03-25 11:13:57.000000000 +0100
-@@ -119,7 +119,7 @@
- char response = 'z';
-
- fp = sign_key_fingerprint(keyblob, keybloblen);
-- fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n",
-+ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n) ",
- cli_opts.remotehost,
- fp);
-
diff --git a/openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch b/openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
deleted file mode 100644
index 9b79e48..0000000
--- a/openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ruN dropbear-0.48-old/cli-runopts.c dropbear-0.48-new/cli-runopts.c
---- dropbear-0.48-old/cli-runopts.c 2006-03-09 16:06:03.000000000 +0100
-+++ dropbear-0.48-new/cli-runopts.c 2006-03-11 12:28:54.000000000 +0100
-@@ -188,6 +188,10 @@
- debug_trace = 1;
- break;
- #endif
-+ case 'o':
-+ next = &dummy;
-+ case 'x':
-+ break;
- case 'F':
- case 'e':
- case 'c':
-@@ -199,7 +203,6 @@
- #ifndef ENABLE_CLI_LOCALTCPFWD
- case 'L':
- #endif
-- case 'o':
- case 'b':
- next = &dummy;
- default:
diff --git a/openwrt/package/dropbear/patches/140-use_dev_urandom.patch b/openwrt/package/dropbear/patches/140-use_dev_urandom.patch
deleted file mode 100644
index e1424f5..0000000
--- a/openwrt/package/dropbear/patches/140-use_dev_urandom.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN dropbear-0.45.old/options.h dropbear-0.45/options.h
---- dropbear-0.45.old/options.h 2005-03-14 17:12:22.000000000 +0100
-+++ dropbear-0.45/options.h 2005-03-14 17:13:49.000000000 +0100
-@@ -143,7 +143,7 @@
- * however significantly reduce the security of your ssh connections
- * if the PRNG state becomes guessable - make sure you know what you are
- * doing if you change this. */
--#define DROPBEAR_RANDOM_DEV "/dev/random"
-+#define DROPBEAR_RANDOM_DEV "/dev/urandom"
-
- /* prngd must be manually set up to produce output */
- /*#define DROPBEAR_PRNGD_SOCKET "/var/run/dropbear-rng"*/
diff --git a/openwrt/package/dropbear/patches/150-dbconvert_standalone.patch b/openwrt/package/dropbear/patches/150-dbconvert_standalone.patch
deleted file mode 100644
index 50c035a..0000000
--- a/openwrt/package/dropbear/patches/150-dbconvert_standalone.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- dropbear-0.47.old/options.h 2006-01-31 13:36:25.301562500 +0100
-+++ dropbear-0.47.dev/options.h 2006-01-31 13:37:41.846346250 +0100
-@@ -5,6 +5,11 @@
- #ifndef _OPTIONS_H_
- #define _OPTIONS_H_
-
-+#if !defined(DROPBEAR_CLIENT) && !defined(DROPBEAR_SERVER)
-+#define DROPBEAR_SERVER
-+#define DROPBEAR_CLIENT
-+#endif
-+
- /******************************************************************
- * Define compile-time options below - the "#ifndef DROPBEAR_XXX .... #endif"
- * parts are to allow for commandline -DDROPBEAR_XXX options etc.